blob: 4f08d6eb647c35dfd156866a88d91830db081dd1 [file] [log] [blame]
Andrew Geisslerd1e89492021-02-12 15:35:20 -06001inherit features_check
2REQUIRED_DISTRO_FEATURES = "ptest"
3
Brad Bishopc342db32019-05-15 21:57:59 -04004require core-image-sato-sdk.bb
5require conf/distro/include/ptest-packagelists.inc
6
7IMAGE_INSTALL += "${PTESTS_FAST}"
8
9DESCRIPTION += "Also includes ptest packages with fast execution times to allow for more automated QA."
10
11# This image is sufficiently large (~1.8GB) that it can't actually fit in a live
12# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
13# box) and explicitly add just 1500MB.
14# strace-ptest in particular needs more than 500MB
15IMAGE_OVERHEAD_FACTOR = "1.0"
16IMAGE_ROOTFS_EXTRA_SPACE = "1524288"
17
18# ptests need more memory than standard to avoid the OOM killer
19QB_MEM = "-m 1024"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21# Sadly at the moment the fast set of ptests is not robust enough and sporadically fails in a couple of places
22PTEST_EXPECT_FAILURE = "1"