blob: 25725e078d69844b65ea7d0615794ca13d710106 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# Copyright (C) 2007-2008 OpenedHand Ltd.
3#
4
5SUMMARY = "Sato desktop"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06006DESCRIPTION = "Packagegroups provide a convenient mechanism of bundling a collection of packages."
7HOMEPAGE = "https://www.yoctoproject.org/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008PR = "r33"
9
10PACKAGE_ARCH = "${MACHINE_ARCH}"
11
Brad Bishop6dbb3162019-11-25 09:41:34 -050012inherit packagegroup features_check
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013REQUIRED_DISTRO_FEATURES = "x11"
14
15PACKAGES = "${PN} ${PN}-base ${PN}-apps ${PN}-games"
16
17RDEPENDS_${PN} = "\
18 ${PN}-base \
19 ${PN}-apps \
20 ${PN}-games \
21 "
22
23NETWORK_MANAGER ?= "connman-gnome"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
25SUMMARY_${PN}-base = "Sato desktop - base packages"
26RDEPENDS_${PN}-base = "\
27 matchbox-desktop \
28 matchbox-session-sato \
29 matchbox-keyboard \
30 matchbox-keyboard-applet \
31 matchbox-keyboard-im \
32 matchbox-config-gtk \
33 xcursor-transparent-theme \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060034 adwaita-icon-theme \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050035 settings-daemon \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036 shutdown-desktop \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050037 ${NETWORK_MANAGER} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '', 'udev-extraconf', d)} \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050039 ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-server pulseaudio-client-conf-sato pulseaudio-misc', '', d)} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040 "
41
Patrick Williamsc124f4f2015-09-15 14:41:29 -050042FILEMANAGER ?= "pcmanfm"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050043
44WEB ?= ""
45#WEB = "epiphany"
46
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047GSTEXAMPLES ?= "gst-examples"
48GSTEXAMPLES_riscv64 = ""
49
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050SUMMARY_${PN}-apps = "Sato desktop - applications"
51RDEPENDS_${PN}-apps = "\
Patrick Williamsc0f7c042017-02-23 20:41:17 -060052 l3afpad \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050053 matchbox-terminal \
54 sato-screenshot \
55 ${FILEMANAGER} \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080056 ${GSTEXAMPLES} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057 ${WEB} \
58 "
59
60SUMMARY_${PN}-games = "Sato desktop - games"
61RDEPENDS_${PN}-games = "\
Patrick Williamsc0f7c042017-02-23 20:41:17 -060062 puzzles \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063 "