blob: d1db562bb555cd8b7925a136e3163ee4489ae6d3 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
Patrick Williamsc0f7c042017-02-23 20:41:17 -06004SUMMARY = "Glibc hierarchical argument parsing standalone library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06005DESCRIPTION = "Standalone version of arguments parsing functions from GLIBC"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006HOMEPAGE = "http://www.lysator.liu.se/~nisse/misc/"
7LICENSE = "LGPL-2.1"
8LIC_FILES_CHKSUM = "file://argp.h;beginline=1;endline=20;md5=008b7e53dea6f9e1d9fdef0d9cf3184a"
9SECTION = "libs"
10
11SRC_URI = "http://www.lysator.liu.se/~nisse/misc/argp-standalone-${PV}.tar.gz \
12 file://0001-throw-in-funcdef.patch \
13 file://0002-isprint.patch \
14 file://out_of_tree_build.patch \
15 "
16SRC_URI[md5sum] = "720704bac078d067111b32444e24ba69"
17SRC_URI[sha256sum] = "dec79694da1319acd2238ce95df57f3680fea2482096e483323fddf3d818d8be"
18
19inherit autotools
20
21CFLAGS += "-fPIC -U__OPTIMIZE__"
22
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023RDEPENDS_${PN}-dev = ""
24RDEPENDS_${PN}-staticdev = ""
25
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050026do_install() {
27 install -D -m 0644 ${B}/libargp.a ${D}${libdir}/libargp.a
28 install -D -m 0644 ${S}/argp.h ${D}${includedir}/argp.h
29}
30#
31# We will skip parsing for non-musl systems
32#
33COMPATIBLE_HOST = ".*-musl.*"