blob: 1aedd8e6f3d6caf10214858428e29497216e3d46 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Miscellaneous utilities specific to Debian"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Provides a number of small utilities which are used \
3primarily by the installation scripts of Debian packages, although \
4you may use them directly. "
5HOMEPAGE = "https://packages.debian.org/sid/debianutils"
6BUGTRACKER = "https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=debianutils;dist=unstable"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007SECTION = "base"
8LICENSE = "GPLv2 & SMAIL_GPL"
Andrew Geissler5a43b432020-06-13 10:46:56 -05009LIC_FILES_CHKSUM = "file://debian/copyright;md5=9b912cd0cc654134c0ef3424a0705b94"
Andrew Geissler82c905d2020-04-13 13:39:40 -050010
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050011SRC_URI = "http://snapshot.debian.org/archive/debian/20200929T025235Z/pool/main/d/${BPN}/${BPN}_${PV}.tar.xz"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012# the package is taken from snapshots.debian.org; that source is static and goes stale
13# so we check the latest upstream from a directory that does get updated
14UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
15
Andrew Geissler6ce62a22020-11-30 19:58:47 -060016SRC_URI[sha256sum] = "3b680e81709b740387335fac8f8806d71611dcf60874e1a792e862e48a1650de"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18inherit autotools update-alternatives
19
Andrew Geissler6ce62a22020-11-30 19:58:47 -060020S = "${WORKDIR}/debianutils"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021do_configure_prepend() {
22 sed -i -e 's:tempfile.1 which.1:which.1:g' ${S}/Makefile.am
23}
24
25do_install_append() {
26 if [ "${base_bindir}" != "${bindir}" ]; then
27 # Debian places some utils into ${base_bindir} as does busybox
28 install -d ${D}${base_bindir}
29 for app in run-parts tempfile; do
30 mv ${D}${bindir}/$app ${D}${base_bindir}/$app
31 done
32 fi
33}
34
35# Note that we package the update-alternatives name.
36#
37PACKAGES =+ "${PN}-run-parts"
38FILES_${PN}-run-parts = "${base_bindir}/run-parts.debianutils"
39
40RDEPENDS_${PN} += "${PN}-run-parts"
41RDEPENDS_${PN}_class-native = ""
42
Andrew Geissler4ed12e12020-06-05 18:00:41 -050043ALTERNATIVE_PRIORITY = "30"
Andrew Geissler82c905d2020-04-13 13:39:40 -050044ALTERNATIVE_${PN} = "add-shell installkernel remove-shell savelog tempfile which"
45
46ALTERNATIVE_PRIORITY_${PN}-run-parts = "60"
47ALTERNATIVE_${PN}-run-parts = "run-parts"
48
49ALTERNATIVE_${PN}-doc = "which.1"
50ALTERNATIVE_LINK_NAME[which.1] = "${mandir}/man1/which.1"
51
Andrew Geissler4ed12e12020-06-05 18:00:41 -050052ALTERNATIVE_LINK_NAME[add-shell] = "${sbindir}/add-shell"
53ALTERNATIVE_LINK_NAME[installkernel] = "${sbindir}/installkernel"
54ALTERNATIVE_LINK_NAME[remove-shell] = "${sbindir}/remove-shell"
55ALTERNATIVE_LINK_NAME[run-parts] = "${base_bindir}/run-parts"
56ALTERNATIVE_LINK_NAME[savelog] = "${bindir}/savelog"
57ALTERNATIVE_LINK_NAME[tempfile] = "${base_bindir}/tempfile"
58ALTERNATIVE_LINK_NAME[which] = "${bindir}/which"
Andrew Geissler82c905d2020-04-13 13:39:40 -050059
60BBCLASSEXTEND = "native"