blob: 94a3f00eac44cf669018e289da69742c3538e0f3 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "New GNU Portable Threads library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "nPth is a library to provide the GNU Pth API and thus a non-preemptive threads implementation. "
Andrew Geissler6ce62a22020-11-30 19:58:47 -06003HOMEPAGE = "https://www.gnu.org/software/pth/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004SECTION = "libs"
5LICENSE = "LGPLv2+"
6LIC_FILES_CHKSUM = "\
7 file://COPYING.LIB;md5=2caced0b25dfefd4c601d92bd15116de\
8 "
9UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
10SRC_URI = "${GNUPG_MIRROR}/npth/npth-${PV}.tar.bz2 \
11 file://pkgconfig.patch \
12 "
13
14SRC_URI[md5sum] = "375d1a15ad969f32d25f1a7630929854"
15SRC_URI[sha256sum] = "1393abd9adcf0762d34798dc34fdcf4d0d22a8410721e76f1e3afcd1daa4e2d1"
16
17BINCONFIG = "${bindir}/npth-config"
18
Andrew Geissler6ce62a22020-11-30 19:58:47 -060019inherit autotools binconfig-disabled multilib_header
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21FILES_${PN} = "${libdir}/libnpth.so.*"
22FILES_${PN}-dev += "${bindir}/npth-config"
23
24do_install_append() {
25 oe_multilib_header npth.h
26}
27
Brad Bishop1d80a2e2019-11-15 16:35:03 -050028BBCLASSEXTEND = "native nativesdk"