blob: 0ab155b081f36026c66e3fff0203c0a2704e04bd [file] [log] [blame]
Kuiying Wang91ff72a2018-11-08 16:52:49 +08001SUMMARY = "OpenBMC Buttons"
2DESCRIPTION = "OpenBMC All buttons"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9SRC_URI += "git://github.com/openbmc/phosphor-buttons.git"
10SRCREV = "f654267db9dafbd5727f113f29439ec7dfeaea8b"
11
12inherit cmake pkgconfig systemd
13
14SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Buttons.service"
15
16DEPENDS += " \
17 systemd \
18 sdbusplus \
19 phosphor-dbus-interfaces \
20 phosphor-logging \
21 nlohmann-json \
22 gpioplus \
23 "