Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 1 | SUMMARY = "Hardware Diagnostics for POWER Systems" |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 2 | |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 3 | DESCRIPTION = \ |
| 4 | "In the event of a system fatal error reported by the internal system \ |
| 5 | hardware (processor chips, memory chips, I/O chips, system memory, etc.), \ |
| 6 | POWER Systems have the ability to diagnose the root cause of the failure \ |
| 7 | and perform any service action needed to avoid repeated system failures." |
| 8 | |
Zane Shelley | 92804a7 | 2021-06-04 17:18:22 -0500 | [diff] [blame^] | 9 | HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags" |
| 10 | |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 11 | LICENSE = "Apache-2.0" |
| 12 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 13 | |
Zane Shelley | 92804a7 | 2021-06-04 17:18:22 -0500 | [diff] [blame^] | 14 | PR = "r1" |
| 15 | PV = "0.1+git${SRCPV}" |
Brad Bishop | fac997f | 2020-02-03 17:09:22 -0500 | [diff] [blame] | 16 | |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 17 | SRC_URI = "git://github.com/openbmc/openpower-hw-diags" |
Andrew Geissler | 0c2d9d5 | 2021-06-02 21:00:22 +0000 | [diff] [blame] | 18 | SRCREV = "6bc43c9b896724c27317ac50a88e5ddaa2882484" |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 19 | |
Zane Shelley | 92804a7 | 2021-06-04 17:18:22 -0500 | [diff] [blame^] | 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | inherit meson systemd |
| 23 | |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 24 | SYSTEMD_SERVICE_${PN} = "attn_handler.service" |
Zane Shelley | 6714373 | 2021-03-23 17:08:45 -0500 | [diff] [blame] | 25 | |
Zane Shelley | b6d95ee | 2021-02-10 17:43:44 -0600 | [diff] [blame] | 26 | DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \ |
| 27 | nlohmann-json" |
| 28 | |
Zane Shelley | 8dff99b | 2020-11-10 19:56:40 -0600 | [diff] [blame] | 29 | # This is required so that libhei is installed with the chip data files. |
| 30 | RDEPENDS_${PN} += "openpower-libhei" |
Zane Shelley | aa8acf1 | 2021-03-23 17:13:08 -0500 | [diff] [blame] | 31 | |
| 32 | # Conditionally pull in PHAL APIs, if available. |
| 33 | PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" |
| 34 | PACKAGECONFIG[phal] = "-Dphal=enabled, -Dphal=disabled, pdata" |
| 35 | |