blob: a0a7284554b58c3b0e1871d2b408be20688b0a6f [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3#
4# Corstone-500 MACHINE
5#
6SRC_URI:append:corstone500 = " \
7 file://0001-armv7-adding-generic-timer-access-through-MMIO.patch \
8 file://0002-board-arm-add-corstone500-board.patch"
9
10#
11# Corstone1000 64-bit machines
12#
13DEPENDS:append:corstone1000 = " gnutls-native"
14CORSTONE1000_DEVICE_TREE:corstone1000-mps3 = "corstone1000-mps3"
15CORSTONE1000_DEVICE_TREE:corstone1000-fvp = "corstone1000-fvp"
16EXTRA_OEMAKE:append:corstone1000 = ' DEVICE_TREE=${CORSTONE1000_DEVICE_TREE}'
17
18SYSROOT_DIRS:append:corstone1000 = " /boot"
19
20SRC_URI:append:corstone1000 = " \
21 file://0001-cmd-load-add-load-command-for-memory-mapped.patch \
22 file://0002-arm-add-support-to-corstone1000-platform.patch \
23 file://0003-usb-common-move-urb-code-to-common.patch \
24 file://0004-usb-add-isp1760-family-driver.patch \
25 file://0005-corstone1000-enable-isp1763-usb-controller.patch \
26 file://0006-arm_ffa-introducing-Arm-FF-A-low-level-driver.patch \
27 file://0007-arm_ffa-introducing-armffa-command.patch \
28 file://0008-arm_ffa-introducing-MM-communication-with-FF-A.patch \
29 file://0009-arm_ffa-introducing-test-module-for-UCLASS_FFA.patch \
30 file://0010-arm_ffa-corstone1000-enable-FF-A-and-MM-support.patch \
31 file://0011-efi-corstone1000-introduce-EFI-capsule-update.patch \
32 file://0012-corstone1000-Update-FFA-shared-buffer-address.patch \
33 file://0013-corstone1000-Make-sure-shared-buffer-contents-are-no.patch \
34 file://0014-arm-corstone1000-fix-unrecognized-filesystem-type.patch \
35 file://0015-efi_capsule-corstone1000-pass-interface-id-and-buffe.patch \
36 file://0016-efi_boottime-corstone1000-pass-interface-id-and-kern.patch \
37 file://0017-efi_loader-corstone1000-remove-guid-check-from-corst.patch \
38 file://0018-arm_ffa-removing-the-cast-when-using-binary-OR-on-FI.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050039 file://0019-Use-correct-buffer-size.patch \
40 file://0020-efi_loader-populate-ESRT-table-if-EFI_ESRT-config-op.patch \
41 file://0021-efi_firmware-add-get_image_info-for-corstone1000.patch \
42 file://0022-efi_loader-send-bootcomplete-message-to-secure-encla.patch \
43 file://0023-efi_loader-fix-null-pointer-exception-with-get_image.patch \
44 file://0024-arm-corstone1000-add-mmc-for-fvp.patch \
45 file://0025-corstone1000-use-a-compressed-kernel.patch \
Brad Bishopbec4ebc2022-08-03 09:55:16 -040046 "
47
48#
49# FVP BASE
50#
51SRC_URI:append:fvp-base = " file://bootargs.cfg"
52
53#
54# FVP BASE ARM32
55#
56SRC_URI:append:fvp-base-arm32 = " file://0001-Add-vexpress_aemv8a_aarch32-variant.patch \
57 file://0002-Revert-vexpress64-Enable-OF_CONTROL-and-OF_BOARD-for.patch \
58 "
59
60#
61# FVP BASER
62#
63SRC_URI:append:fvp-baser-aemv8r64 = " \
64 file://0001-armv8-Add-ARMv8-MPU-configuration-logic.patch \
65 file://0002-vexpress64-add-MPU-memory-map-for-the-BASER_FVP.patch \
66 file://0003-armv8-Allow-disabling-exception-vectors-on-non-SPL-b.patch \
67 file://0004-armv8-ARMV8_SWITCH_TO_EL1-improvements.patch \
68 file://0005-armv8-Make-disabling-HVC-configurable-when-switching.patch \
69 file://0006-vexpress64-Do-not-set-COUNTER_FREQUENCY.patch \
70 file://0007-vexpress64-Enable-LIBFDT_OVERLAY-in-the-vexpress_aem.patch \
71 file://0008-armv8-Allow-PRBAR-MPU-attributes-to-be-configured.patch \
72 file://0009-armv8-Enable-icache-when-switching-exception-levels-.patch \
73 "
74
75
76#
77# Juno Machines
78#
79SRC_URI:append:juno = " file://0001-arm-juno-add-custom-bootcmd-to-autoboot-from-uEnv.tx.patch"
80
81
82#
83# TC0 and TC1 MACHINES
84#
85SRC_URI:append:tc = " \
86 file://bootargs.cfg \
87 file://0001-arm-total_compute-update-secure-dram-size.patch \
88 "