blob: 68cf8795a6a45ecd72ad4b8da75f545337941d57 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "TinyALSA is a small library to interface with ALSA in \
2the Linux kernel. It is a lightweight alternative to libasound."
3HOMEPAGE = "https://github.com/tinyalsa/tinyalsa"
4SECTION = "libs/multimedia"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://NOTICE;md5=dbdefe400d894b510a9de14813181d0b"
8
Brad Bishop00ab2372019-10-14 11:06:18 -04009SRCREV = "8449529c7e50f432091539ba7b438e79b04059b5"
Andrew Geissler595f6302022-01-24 19:11:47 +000010SRC_URI = "git://github.com/tinyalsa/tinyalsa;branch=master;protocol=https \
Brad Bishope42b3e32020-01-15 22:08:42 -050011 file://0001-Use-CMAKE_INSTALL_-path-instead-of-hardcoding-bin-li.patch \
12 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013PV = "1.1.1+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17inherit cmake
18
19# tinyalsa is built as a static library. Enable PIC to avoid relocation
20# errors like these:
21#
22# unresolvable R_AARCH64_ADR_PREL_PG_HI21 relocation against symbol `stderr@@GLIBC_2.17'
23CFLAGS += " -fPIC -DPIC "