blob: cc2c1571e641f3ea6ff27ecb750c61850cb11975 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.github.io/"
9
10SECTION = "libs"
11LICENSE = "GD"
Andrew Geissler5199d832021-09-24 16:47:35 -050012LIC_FILES_CHKSUM = "file://COPYING;md5=ace63adfdac78400fc30fa22ee9c1bb1"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
Andrew Geissler595f6302022-01-24 19:11:47 +000016SRC_URI = "git://github.com/libgd/libgd.git;nobranch=1;protocol=https \
Patrick Williams92b42cb2022-09-03 06:53:57 -050017 file://0001-Fix-deprecared-function-prototypes.patch \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050018 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
Andrew Geissler5199d832021-09-24 16:47:35 -050020SRCREV = "b5319a41286107b53daa0e08e402aa1819764bdc"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
22S = "${WORKDIR}/git"
23
24inherit autotools binconfig gettext pkgconfig
25
26EXTRA_OECONF += " --disable-rpath \
27 --with-jpeg=${STAGING_LIBDIR}/.. \
28 --with-freetype=yes \
29 --without-fontconfig \
30 --without-webp \
31 --without-xpm \
32 --without-x \
33 "
34
35EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
36
Patrick Williams213cb262021-08-07 19:21:33 -050037DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
Andrew Geissler82c905d2020-04-13 13:39:40 -050038
Patrick Williams213cb262021-08-07 19:21:33 -050039do_install:append:class-target() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 # cleanup buildpaths from gdlib.pc
41 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
42}
43
44PACKAGES += "${PN}-tools"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046FILES:${PN} = "${libdir}/lib*${SOLIBS}"
47FILES:${PN}-tools = "${bindir}/*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050048
49PROVIDES += "${PN}-tools"
Patrick Williams213cb262021-08-07 19:21:33 -050050RPROVIDES:${PN}-tools = "${PN}-tools"
51RDEPENDS:${PN}-tools = "perl perl-module-strict"
Andrew Geissler82c905d2020-04-13 13:39:40 -050052
53CVE_PRODUCT = "libgd"
Andrew Geissler89770b02020-06-13 10:40:47 -050054
55BBCLASSEXTEND = "native nativesdk"