Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Interactive process viewer" |
| 2 | HOMEPAGE = "https://htop.dev" |
| 3 | SECTION = "console/utils" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | DEPENDS = "ncurses" |
| 8 | |
| 9 | SRC_URI = "git://github.com/htop-dev/htop.git;branch=main;protocol=https \ |
| 10 | file://0001-Use-pkg-config.patch \ |
| 11 | " |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 12 | SRCREV = "4e6ec4a0873c56ca9de63eadf730c5bd677bd8da" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit autotools pkgconfig |
| 17 | |
| 18 | PACKAGECONFIG ??= " \ |
| 19 | unicode \ |
| 20 | affinity \ |
| 21 | delayacct \ |
| 22 | " |
| 23 | PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode" |
| 24 | PACKAGECONFIG[affinity] = "--enable-affinity,--disable-affinity,,,,hwloc" |
| 25 | PACKAGECONFIG[unwind] = "--enable-unwind,--disable-unwind,libunwind" |
| 26 | PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc,,,affinity" |
| 27 | PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz" |
| 28 | PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver" |
| 29 | PACKAGECONFIG[ancient-vserver] = "--enable-ancient-vserver,--disable-ancient-vserver" |
| 30 | PACKAGECONFIG[capabilities] = "--enable-capabilities,--disable-capabilities,libcap" |
| 31 | PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl" |
| 32 | PACKAGECONFIG[sensors] = "--enable-sensors,--disable-sensors,lmsensors,lmsensors-libsensors" |
| 33 | |
| 34 | FILES:${PN} += "${datadir}/icons/hicolor/scalable/apps/htop.svg" |
| 35 | |
| 36 | RDEPENDS:${PN} += "ncurses-terminfo-base" |