blob: a0b1feb70ad8472fac833bf8345f17a16e9b4e13 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7inherit python_pep517 python3native python3-dir setuptools3-base
8
9DEPENDS += "python3 python3-flit-core-native"
10
11python_flit_core_do_manual_build () {
12 cd ${PEP517_SOURCE_PATH}
13 nativepython3 -m flit_core.wheel --outdir ${PEP517_WHEEL_PATH} .
14}