blob: 404f5fd9f2272a65e6daf5f77fa6b706a8484d1f [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001#
Patrick Williams92b42cb2022-09-03 06:53:57 -05002# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7#
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008# This class is used by yocto-check-layer script for additional per-recipe tests
9# The first test ensures that the layer has no recipes skipping 'installed-vs-shipped' QA checks
10#
11
12WARN_QA:remove = "installed-vs-shipped"
13ERROR_QA:append = " installed-vs-shipped"
14
15python () {
16 packages = set((d.getVar('PACKAGES') or '').split())
17 for package in packages:
18 skip = set((d.getVar('INSANE_SKIP') or "").split() +
19 (d.getVar('INSANE_SKIP:' + package) or "").split())
20 if 'installed-vs-shipped' in skip:
21 oe.qa.handle_error("installed-vs-shipped", 'Package %s is skipping "installed-vs-shipped" QA test.' % package, d)
22}