blob: d803db867210c1cceee639ea7b1f6f11b57d1344 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/libxml2"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=e77f77b12cb69e203d8b4090a0eee879 \
9 file://list.c;beginline=4;endline=13;md5=b9c25b021ccaf287e50060602d20f3a7 \
10 file://trio.c;beginline=5;endline=14;md5=cd4f61e27f88c1d43df112966b1cd28f"
11
12DEPENDS = "zlib virtual/libiconv"
13
14inherit gnomebase
15
16SRC_URI += "http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
17 file://libxml-64bit.patch \
18 file://runtest.patch \
19 file://run-ptest \
20 file://python-sitepackages-dir.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
23 file://remove-fuzz-from-ptests.patch \
24 file://libxml-m4-use-pkgconfig.patch \
25 "
Andrew Geissler9aee5002022-03-30 16:27:02 +000026
Andrew Geisslerd5838332022-05-27 11:33:10 -050027SRC_URI[archive.sha256sum] = "60d74a257d1ccec0475e749cba2f21559e48139efba6ff28224357c7c798dfee"
Andrew Geissler9aee5002022-03-30 16:27:02 +000028SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
29
30BINCONFIG = "${bindir}/xml2-config"
31
Patrick Williams92b42cb2022-09-03 06:53:57 -050032# Fixed since 2.9.11 via
33# https://gitlab.gnome.org/GNOME/libxml2/-/commit/c1ba6f54d32b707ca6d91cb3257ce9de82876b6f
34CVE_CHECK_IGNORE += "CVE-2016-3709"
35
Andrew Geissler9aee5002022-03-30 16:27:02 +000036PACKAGECONFIG ??= "python \
37 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
38"
39PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
40PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
41
42inherit autotools pkgconfig binconfig-disabled ptest
43
44inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
45
46RDEPENDS:${PN}-ptest += "bash make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
47
48RDEPENDS:${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
49
50RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-gconv-ebcdic-us \
51 glibc-gconv-ibm1141 \
52 glibc-gconv-iso8859-5 \
53 glibc-gconv-euc-jp \
54 locale-base-en-us \
55 "
56
57export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
58
59# WARNING: zlib is required for RPM use
60EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
61EXTRA_OECONF:class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
62EXTRA_OECONF:class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
63EXTRA_OECONF:linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
64
65python populate_packages:prepend () {
66 # autonamer would call this libxml2-2, but we don't want that
67 if d.getVar('DEBIAN_NAMES'):
68 d.setVar('PKG:libxml2', '${MLPREFIX}libxml2')
69}
70
71PACKAGE_BEFORE_PN += "${PN}-utils"
72PACKAGES += "${PN}-python"
73
74FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
75FILES:${PN}-dev += "${libdir}/xml2Conf.sh"
76FILES:${PN}-utils = "${bindir}/*"
77FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
78
79do_configure:prepend () {
80 # executables take longer to package: these should not be executable
81 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
82}
83
84do_compile_ptest() {
85 oe_runmake check-am
86}
87
88do_install_ptest () {
89 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
90 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
91 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
92 ${D}${PTEST_PATH}/python/tests/Makefile
93 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
94 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
95 fi
96 #Remove build host references from various Makefiles
97 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
98 sed -i \
99 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
100 -e 's|${DEBUG_PREFIX_MAP}||g' \
101 -e 's:${HOSTTOOLS_DIR}/::g' \
102 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
103 -e 's:${RECIPE_SYSROOT}::g' \
104 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
105 -e '/^RELDATE/d' \
106 {} +
107}
108
109do_install:append:class-native () {
110 # Docs are not needed in the native case
111 rm ${D}${datadir}/gtk-doc -rf
Patrick Williams92b42cb2022-09-03 06:53:57 -0500112
113 create_wrapper ${D}${bindir}/xmllint XML_CATALOG_FILES=${sysconfdir}/xml/catalog
Andrew Geissler9aee5002022-03-30 16:27:02 +0000114}
115
116BBCLASSEXTEND = "native nativesdk"