blob: 17ce901646aedb598e5247951d2c460134803f3e [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Perl-cross build system"
2HOMEPAGE = "https://github.com/arsv/perl-cross"
3DESCRIPTION = "perl-cross provides configure script, top-level Makefile and some auxiliary files for perl, \
4with the primary emphasis on cross-compiling the source."
5SECTION = "devel"
6LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
7# README.md is taken from https://github.com/arsv/perl-cross/blob/master/README.md
8# but is not provided inside the release tarballs
9LIC_FILES_CHKSUM = "file://${WORKDIR}/README.md;md5=252fcce2026b765fee1ad74d2fb07a3b"
10
11inherit allarch
12
13SRC_URI = "https://github.com/arsv/perl-cross/releases/download/${PV}/perl-cross-${PV}.tar.gz;name=perl-cross \
14 file://README.md \
15 file://0001-perl-cross-add-LDFLAGS-when-linking-libperl.patch \
16 file://determinism.patch \
17 file://0001-Makefile-check-the-file-if-patched-or-not.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050018 file://0001-configure_func.sh-Add-_GNU_SOURCE-define-and-functio.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000019 "
20UPSTREAM_CHECK_URI = "https://github.com/arsv/perl-cross/releases/"
21
Andrew Geissler78b72792022-06-14 06:47:25 -050022SRC_URI[perl-cross.sha256sum] = "be9d9f9f7148edff7a2f9695ba3cb7e3975eff6b25a9a81dd311725fd757aa91"
Andrew Geissler9aee5002022-03-30 16:27:02 +000023
24S = "${WORKDIR}/perl-cross-${PV}"
25
26do_configure () {
27}
28
29do_compile () {
30}
31
32do_install:class-native() {
33 mkdir -p ${D}/${datadir}/perl-cross/
34 cp -rf ${S}/* ${D}/${datadir}/perl-cross/
35 rm -rf ${D}/${datadir}/perl-cross/patches/
36}
37
38BBCLASSEXTEND = "native"
39