blob: f60ab3b5f5196432055c5bd552ee4cd18f63759a [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SECTION = "devel"
2SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
3DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
4HOMEPAGE = "https://lttng.org/"
5LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
7
8inherit module
9
10include lttng-platforms.inc
11
Patrick Williams03907ee2022-05-01 06:28:52 -050012SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
Patrick Williams03907ee2022-05-01 06:28:52 -050013 file://0009-Rename-genhd-wrapper-to-blkdev.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050014 file://0001-fix-mm-page_alloc-fix-tracepoint-mm_page_alloc_zone_.patch \
15 file://0002-fix-fs-Remove-flags-parameter-from-aops-write_begin-.patch \
16 file://0003-fix-workqueue-Fix-type-of-cpu-in-trace-event-v5.19.patch \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050017 file://0001-fix-net-skb-introduce-kfree_skb_reason-v5.15.58.v5.1.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050018 file://0001-fix-compaction.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050019 "
Patrick Williams03907ee2022-05-01 06:28:52 -050020
Andrew Geissler9aee5002022-03-30 16:27:02 +000021# Use :append here so that the patch is applied also when using devupstream
22SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
23
Andrew Geissler615f2f12022-07-15 14:00:58 -050024SRC_URI[sha256sum] = "6159d00e4e1d59546eec8d4a67e1aa39c1084ceb5e5afeb666eab4b8a5b5a9ee"
Andrew Geissler9aee5002022-03-30 16:27:02 +000025
26export INSTALL_MOD_DIR="kernel/lttng-modules"
27
28EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
29
30MODULES_MODULE_SYMVERS_LOCATION = "src"
31
32do_install:append() {
33 # Delete empty directories to avoid QA failures if no modules were built
34 if [ -d ${D}/${nonarch_base_libdir} ]; then
35 find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
36 fi
37}
38
39python do_package:prepend() {
40 if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
41 bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
42}
43
44BBCLASSEXTEND = "devupstream:target"
45SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
46SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
47SRCREV_FORMAT ?= "lttng_git"