blob: 10614fe37447913886176a30d95d16f318163190 [file] [log] [blame]
Andrew Geisslerd688a012020-09-18 13:36:00 -05001SUMMARY = "Python interface for libsystemd"
2HOMEPAGE = "https://github.com/systemd/python-systemd"
Andrew Geissler9aee5002022-03-30 16:27:02 +00003LICENSE = "LGPL-2.1-or-later"
Andrew Geisslerd688a012020-09-18 13:36:00 -05004LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4fbd65380cdd255951079008b364516c"
5
6PYPI_PACKAGE = "systemd-python"
7DEPENDS += "systemd (<=234)"
Patrick Williams213cb262021-08-07 19:21:33 -05008RDEPENDS:${PN} += "systemd ${PYTHON_PN}-syslog ${PYTHON_PN}-logging python3-syslog"
Andrew Geisslerd688a012020-09-18 13:36:00 -05009REQUIRED_DISTRO_FEATURES = "systemd"
Andrew Geissler5199d832021-09-24 16:47:35 -050010inherit pypi features_check pkgconfig setuptools3
Andrew Geisslerd688a012020-09-18 13:36:00 -050011
12SRC_URI[md5sum] = "5071ea5bcb976186e92a3f5e75df221d"
13SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895db83e7"
14
15# allow for common patches for python- and python3-systemd
Patrick Williams213cb262021-08-07 19:21:33 -050016FILESEXTRAPATHS:prepend := "${THISDIR}/python-systemd:"
Andrew Geisslerd688a012020-09-18 13:36:00 -050017
Andrew Geissler9aee5002022-03-30 16:27:02 +000018SRC_URI += " \
19 file://endian.patch \
20 file://0002-setup.py-switch-from-distutils-to-setuptools.patch \
21"
Andrew Geisslerd688a012020-09-18 13:36:00 -050022
Patrick Williams213cb262021-08-07 19:21:33 -050023SRC_URI:append:libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch"