Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "The Perl Database Interface" |
| 2 | DESCRIPTION = "DBI is a database access Application Programming Interface \ |
| 3 | (API) for the Perl Language. The DBI API Specification defines a set \ |
| 4 | of functions, variables and conventions that provide a consistent \ |
| 5 | database interface independent of the actual database being used. \ |
| 6 | " |
| 7 | HOMEPAGE = "http://search.cpan.org/dist/DBI/" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=10982c7148e0a012c0fd80534522f5c5" |
| 11 | |
Patrick Williams | 0ca19cc | 2021-08-16 14:03:13 -0500 | [diff] [blame] | 12 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/DBI-${PV}.tar.gz \ |
| 13 | file://CVE-2014-10402.patch \ |
| 14 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 15 | SRC_URI[md5sum] = "352f80b1e23769c116082a90905d7398" |
| 16 | SRC_URI[sha256sum] = "8a2b993db560a2c373c174ee976a51027dd780ec766ae17620c20393d2e836fa" |
| 17 | |
| 18 | S = "${WORKDIR}/DBI-${PV}" |
| 19 | |
| 20 | inherit cpan ptest-perl |
| 21 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 22 | do_install:prepend() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | # test requires "-T" (taint) command line option |
| 24 | rm -rf ${B}/t/pod-coverage.t |
| 25 | rm -rf ${B}/t/13taint.t |
| 26 | # source of test failure not obvious |
| 27 | rm -rf ${B}/t/85gofer.t |
| 28 | # unclear why there are several duplicates of tests in tarball |
| 29 | rm -rf ${B}/t/z*.t |
| 30 | } |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | RDEPENDS:${PN}:class-target = " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | perl \ |
| 34 | perl-module-carp \ |
| 35 | perl-module-exporter \ |
| 36 | perl-module-exporter-heavy \ |
| 37 | perl-module-dynaloader \ |
| 38 | perl-module-io-dir \ |
| 39 | perl-module-scalar-util \ |
| 40 | perl-module-universal \ |
| 41 | " |
| 42 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | RDEPENDS:${PN}-ptest = " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | ${PN} \ |
| 45 | perl-module-b \ |
| 46 | perl-module-benchmark \ |
| 47 | perl-module-cwd \ |
| 48 | perl-module-data-dumper \ |
| 49 | perl-module-encode \ |
| 50 | perl-module-encode-byte \ |
| 51 | perl-module-encode-encoding \ |
| 52 | perl-module-file-copy \ |
| 53 | perl-module-file-path \ |
| 54 | perl-module-lib \ |
| 55 | perl-module-perlio \ |
| 56 | perl-module-perlio-scalar \ |
| 57 | perl-module-perlio-via \ |
| 58 | perl-module-sdbm-file \ |
| 59 | perl-module-storable \ |
| 60 | perl-module-test-more \ |
| 61 | perl-module-utf8 \ |
| 62 | " |
| 63 | |
| 64 | BBCLASSEXTEND = "native" |