blob: 8345d6880fae15b3e0d58d280624594d33bcaf18 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "Audio Sample Rate Conversion library"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "Also known as Secret Rabbit Code - a library for performing sample rate conversion of audio data."
Brad Bishop6e60e8b2018-02-01 10:27:11 -05003HOMEPAGE = "http://www.mega-nerd.com/SRC/"
4SECTION = "libs"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=336d6faf40fb600bafb0061f4052f1f4 \
7 file://src/samplerate.c;beginline=1;endline=7;md5=5b6982a8c2811c7312c13cccbf55f55e"
8DEPENDS = "libsndfile1"
9PR = "r1"
10
11SRC_URI = "http://www.mega-nerd.com/SRC/libsamplerate-${PV}.tar.gz \
12 file://0001-configure.ac-improve-alsa-handling.patch \
Patrick Williams93c203f2021-10-06 16:15:23 -050013 file://shared_version_info.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014"
15
16SRC_URI[md5sum] = "2b78ae9fe63b36b9fbb6267fad93f259"
17SRC_URI[sha256sum] = "0a7eb168e2f21353fb6d84da152e4512126f7dc48ccb0be80578c565413444c1"
18
19CVE_PRODUCT = "libsamplerate"
20
21UPSTREAM_CHECK_URI = "http://www.mega-nerd.com/SRC/download.html"
22
23S = "${WORKDIR}/libsamplerate-${PV}"
24
25inherit autotools pkgconfig
26
27# FFTW and ALSA are only used in tests and examples, so they don't affect
28# normal builds. It should be safe to ignore these, but explicitly disabling
29# them adds some extra certainty that builds are deterministic.
30EXTRA_OECONF = "--disable-fftw --disable-alsa"