blob: 35c27141538a4359bbd19c54636f990212ef62c0 [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Common code for dbus applications using python.
2
3inherit allarch
4inherit obmc-phosphor-systemd
5inherit obmc-phosphor-license
6
7RDEPENDS_${PN} += "python-dbus python-pygobject"
8SRC_URI += " \
9 file://${PN}.py \
10 "
11S = "${WORKDIR}"
12
13do_install_append() {
14 # install the script
15 install -d ${D}${sbindir}
16 install -m 0755 ${WORKDIR}/${PN}.py ${D}${sbindir}/${PN}
17}