blob: d1aa5de8dfee59701cbd2395a062cc49cfa9a4cb [file] [log] [blame]
Andrew Geissler4ed12e12020-06-05 18:00:41 -05001SUMMARY = "Advanced front-end for dpkg"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "APT is the Advanced Package Tool, an advanced interface to the Debian packaging system which provides the apt-get program."
3HOMEPAGE = "https://packages.debian.org/jessie/apt"
Andrew Geissler4ed12e12020-06-05 18:00:41 -05004LICENSE = "GPLv2.0+"
5SECTION = "base"
6
7# Triehash script taken from https://github.com/julian-klode/triehash
8SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/${BPN}_${PV}.tar.xz \
9 file://triehash \
10 file://0001-Disable-documentation-directory-altogether.patch \
11 file://0001-Fix-musl-build.patch \
12 file://0001-CMakeLists.txt-avoid-changing-install-paths-based-on.patch \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050013 file://0001-srvrec-Keep-support-for-older-resolver.patch \
14 file://0001-cmake-Do-not-build-po-files.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050015 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -050016
Andrew Geissler4ed12e12020-06-05 18:00:41 -050017SRC_URI_append_class-native = " \
18 file://0001-Do-not-init-tables-from-dpkg-configuration.patch \
19 file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050020 "
21
Andrew Geisslerd1e89492021-02-12 15:35:20 -060022SRC_URI_append_class-nativesdk = " \
23 file://0001-Do-not-init-tables-from-dpkg-configuration.patch \
24 file://0001-Revert-always-run-dpkg-configure-a-at-the-end-of-our.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060025 "
26
Andrew Geissler95ac1b82021-03-31 14:34:31 -050027SRC_URI[sha256sum] = "c5449a4c2126a12497a9949cd10209926005d329f6ce7942a3781fa2fcf50487"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050028LIC_FILES_CHKSUM = "file://COPYING.GPL;md5=b234ee4d69f5fce4486a80fdaf4a4263"
29
30# the package is taken from snapshots.debian.org; that source is static and goes stale
31# so we check the latest upstream from a directory that does get updated
32UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/a/apt/"
33
Andrew Geisslerd1e89492021-02-12 15:35:20 -060034inherit cmake perlnative bash-completion upstream-version-is-even useradd
Andrew Geissler4ed12e12020-06-05 18:00:41 -050035
Andrew Geisslerd1e89492021-02-12 15:35:20 -060036# User is added to allow apt to drop privs, will runtime warn without
37USERADD_PACKAGES = "${PN}"
38USERADD_PARAM_${PN} = "--system --home /nonexistent --no-create-home _apt"
39
40BBCLASSEXTEND = "native nativesdk"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050041
Andrew Geissler95ac1b82021-03-31 14:34:31 -050042DEPENDS += "db gnutls lz4 zlib bzip2 xz libgcrypt xxhash"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050043
Andrew Geisslerd1e89492021-02-12 15:35:20 -060044EXTRA_OECMAKE_append = " -DCURRENT_VENDOR=debian -DWITH_DOC=False \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050045 -DDPKG_DATADIR=${datadir}/dpkg \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060046 -DTRIEHASH_EXECUTABLE=${WORKDIR}/triehash \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050047 -DWITH_TESTS=False \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060048"
Andrew Geissler4ed12e12020-06-05 18:00:41 -050049
50do_configure_prepend () {
51 echo "set( CMAKE_FIND_ROOT_PATH_MODE_INCLUDE BOTH )" >> ${WORKDIR}/toolchain.cmake
52
53}
54
55# Unfortunately apt hardcodes this all over the place
56FILES_${PN} += "${prefix}/lib/dpkg ${prefix}/lib/apt"
57RDEPENDS_${PN} += "bash perl dpkg"
58
Andrew Geisslerd1e89492021-02-12 15:35:20 -060059customize_apt_conf_sample() {
Andrew Geissler4ed12e12020-06-05 18:00:41 -050060 cat > ${D}${sysconfdir}/apt/apt.conf.sample << EOF
61Dir "${STAGING_DIR_NATIVE}/"
62{
63 State "var/lib/apt/"
64 {
65 Lists "#APTCONF#/lists/";
66 status "#ROOTFS#/var/lib/dpkg/status";
67 };
68 Cache "var/cache/apt/"
69 {
70 Archives "archives/";
71 pkgcache "";
72 srcpkgcache "";
73 };
74 Bin "${STAGING_BINDIR_NATIVE}/"
75 {
76 methods "${STAGING_LIBDIR}/apt/methods/";
77 gzip "/bin/gzip";
78 dpkg "dpkg";
79 dpkg-source "dpkg-source";
80 dpkg-buildpackage "dpkg-buildpackage";
81 apt-get "apt-get";
82 apt-cache "apt-cache";
83 };
84 Etc "#APTCONF#"
85 {
86 Preferences "preferences";
87 };
88 Log "var/log/apt";
89};
90
91APT
92{
93 Install-Recommends "true";
94 Immediate-Configure "false";
95 Architecture "i586";
96 Get
97 {
98 Assume-Yes "true";
99 };
100};
101
102Acquire
103{
104 AllowInsecureRepositories "true";
105};
106
107DPkg::Options {"--root=#ROOTFS#";"--admindir=#ROOTFS#/var/lib/dpkg";"--force-all";"--no-debsig"};
108DPkg::Path "";
109EOF
110}
111
Andrew Geisslerd1e89492021-02-12 15:35:20 -0600112do_install_append_class-native() {
113 customize_apt_conf_sample
114}
115
116do_install_append_class-nativesdk() {
117 customize_apt_conf_sample
118}
119
120
Andrew Geissler4ed12e12020-06-05 18:00:41 -0500121do_install_append_class-target() {
122 #Write the correct apt-architecture to apt.conf
123 APT_CONF=${D}/etc/apt/apt.conf
124 echo 'APT::Architecture "${DPKG_ARCH}";' > ${APT_CONF}
125}
126
127# Avoid non-reproducible -src package
128do_install_append () {
129 sed -i -e "s,${B},,g" \
130 ${B}/apt-pkg/tagfile-keys.cc
131}