blob: dbdf563f874d6bdbaf2a5cf50756b680afb150d4 [file] [log] [blame]
Andrew Geisslerc3d88e42020-10-02 09:45:00 -05001DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002HOMEPAGE = "https://pypi.org/project/Jinja/"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -05003
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
6
Andrew Geissler9b4d8b02021-02-19 12:26:16 -06007SRC_URI[sha256sum] = "a6d58433de0ae800347cab1fa3043cebbabe8baa9d29e668f1c768cb87a333c6"
Andrew Geisslerc3d88e42020-10-02 09:45:00 -05008
9PYPI_PACKAGE = "Jinja2"
10
Andrew Geissler95ac1b82021-03-31 14:34:31 -050011CVE_PRODUCT = "jinja2 jinja"
12
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050013CLEANBROKEN = "1"
14
15inherit pypi setuptools3
16# ptest disabled in OE-Core for now due to missing dependencies
17
18
19SRC_URI += " \
20 file://run-ptest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS_${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30 ${PYTHON_PN}-unixadmin \
31"
32
33RDEPENDS_${PN} += " \
34 ${PYTHON_PN}-asyncio \
35 ${PYTHON_PN}-crypt \
36 ${PYTHON_PN}-io \
37 ${PYTHON_PN}-json \
38 ${PYTHON_PN}-markupsafe \
39 ${PYTHON_PN}-math \
40 ${PYTHON_PN}-netclient \
41 ${PYTHON_PN}-numbers\
42 ${PYTHON_PN}-pickle \
43 ${PYTHON_PN}-pprint \
44 ${PYTHON_PN}-shell \
45 ${PYTHON_PN}-threading \
46"
47
48BBCLASSEXTEND = "native nativesdk"