blob: 2787b270fac807ebb822d91d81ad8b49b4f867a7 [file] [log] [blame]
Andrew Geissler5a43b432020-06-13 10:46:56 -05001SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "https://github.com/xinetd-org/xinetd"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "xinetd is a powerful replacement for inetd, xinetd has access control mechanisms, extensive logging capabilities, the ability to make services available based on time, can place limits on the number of servers that can be started, and has deployable defence mechanisms to protect against port scanners, among other things."
Andrew Geissler5a43b432020-06-13 10:46:56 -05004
5# xinetd is a BSD-like license
6# Apple and Gentoo say BSD here.
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f"
9
10UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
11
12SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \
13 file://xinetd.init \
14 file://xinetd.default \
15 file://xinetd.service \
16 "
17
18SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4"
19
20S = "${WORKDIR}/git"
21
22inherit autotools update-rc.d systemd pkgconfig
23
24SYSTEMD_SERVICE_${PN} = "xinetd.service"
25
26INITSCRIPT_NAME = "xinetd"
27INITSCRIPT_PARAMS = "defaults"
28
29PACKAGECONFIG ??= "tcp-wrappers"
30PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
31
32CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"
33
34do_install_append() {
35 install -d "${D}${sysconfdir}/init.d"
36 install -d "${D}${sysconfdir}/default"
37 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
38 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
39
40 # Install systemd unit files
41 install -d ${D}${systemd_unitdir}/system
42 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system
43 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
44 -e 's,@SBINDIR@,${sbindir},g' \
45 ${D}${systemd_unitdir}/system/xinetd.service
46}
47
48RDEPENDS_${PN} += "perl"