blob: 08be38ca50756aa15c12cf2425cc92f71ada96c8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A complete, cross-platform solution to record, convert and stream audio and video."
2DESCRIPTION = "FFmpeg is the leading multimedia framework, able to decode, encode, transcode, \
3 mux, demux, stream, filter and play pretty much anything that humans and machines \
4 have created. It supports the most obscure ancient formats up to the cutting edge."
5HOMEPAGE = "https://www.ffmpeg.org/"
6SECTION = "libs"
7
8LICENSE = "BSD & GPLv2+ & LGPLv2.1+ & MIT"
9LICENSE_${PN} = "GPLv2+"
10LICENSE_libavcodec = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
11LICENSE_libavdevice = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
12LICENSE_libavfilter = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
13LICENSE_libavformat = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
14LICENSE_libavresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
15LICENSE_libavutil = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
16LICENSE_libpostproc = "GPLv2+"
17LICENSE_libswresample = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
18LICENSE_libswscale = "${@bb.utils.contains('PACKAGECONFIG', 'gpl', 'GPLv2+', 'LGPLv2.1+', d)}"
19LICENSE_FLAGS = "commercial"
20
21LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
22 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
23 file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
24 file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
25
26SRC_URI = "https://www.ffmpeg.org/releases/${BP}.tar.xz \
27 file://mips64_cpu_detection.patch \
Andrew Geissler09209ee2020-12-13 08:44:15 -060028 file://0001-libavutil-include-assembly-with-full-path-from-sourc.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050029 "
Andrew Geissler95ac1b82021-03-31 14:34:31 -050030SRC_URI[sha256sum] = "46e4e64f1dd0233cbc0934b9f1c0da676008cad34725113fb7f802cfa84ccddb"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
32# Build fails when thumb is enabled: https://bugzilla.yoctoproject.org/show_bug.cgi?id=7717
33ARM_INSTRUCTION_SET_armv4 = "arm"
34ARM_INSTRUCTION_SET_armv5 = "arm"
35ARM_INSTRUCTION_SET_armv6 = "arm"
36
37# Should be API compatible with libav (which was a fork of ffmpeg)
38# libpostproc was previously packaged from a separate recipe
39PROVIDES = "libav libpostproc"
40
41DEPENDS = "nasm-native"
42
43inherit autotools pkgconfig
44
45PACKAGECONFIG ??= "avdevice avfilter avcodec avformat swresample swscale postproc avresample \
Andrew Geissler95ac1b82021-03-31 14:34:31 -050046 alsa bzlib lzma pic pthreads shared theora zlib \
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060047 ${@bb.utils.contains('AVAILTUNES', 'mips32r2', 'mips32r2', '', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050048 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xv xcb', '', d)}"
49
50# libraries to build in addition to avutil
51PACKAGECONFIG[avdevice] = "--enable-avdevice,--disable-avdevice"
52PACKAGECONFIG[avfilter] = "--enable-avfilter,--disable-avfilter"
53PACKAGECONFIG[avcodec] = "--enable-avcodec,--disable-avcodec"
54PACKAGECONFIG[avformat] = "--enable-avformat,--disable-avformat"
55PACKAGECONFIG[swresample] = "--enable-swresample,--disable-swresample"
56PACKAGECONFIG[swscale] = "--enable-swscale,--disable-swscale"
57PACKAGECONFIG[postproc] = "--enable-postproc,--disable-postproc"
58PACKAGECONFIG[avresample] = "--enable-avresample,--disable-avresample"
59
60# features to support
61PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
Andrew Geissler475cb722020-07-10 16:00:51 -050062PACKAGECONFIG[altivec] = "--enable-altivec,--disable-altivec,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050063PACKAGECONFIG[bzlib] = "--enable-bzlib,--disable-bzlib,bzip2"
64PACKAGECONFIG[fdk-aac] = "--enable-libfdk-aac --enable-nonfree,--disable-libfdk-aac,fdk-aac"
65PACKAGECONFIG[gpl] = "--enable-gpl,--disable-gpl"
66PACKAGECONFIG[gsm] = "--enable-libgsm,--disable-libgsm,libgsm"
67PACKAGECONFIG[jack] = "--enable-indev=jack,--disable-indev=jack,jack"
68PACKAGECONFIG[libvorbis] = "--enable-libvorbis,--disable-libvorbis,libvorbis"
69PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz"
70PACKAGECONFIG[mfx] = "--enable-libmfx,--disable-libmfx,intel-mediasdk"
71PACKAGECONFIG[mp3lame] = "--enable-libmp3lame,--disable-libmp3lame,lame"
72PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
73PACKAGECONFIG[sdl2] = "--enable-sdl2,--disable-sdl2,virtual/libsdl2"
74PACKAGECONFIG[speex] = "--enable-libspeex,--disable-libspeex,speex"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060075PACKAGECONFIG[srt] = "--enable-libsrt,--disable-libsrt,srt"
Andrew Geissler82c905d2020-04-13 13:39:40 -050076PACKAGECONFIG[theora] = "--enable-libtheora,--disable-libtheora,libtheora libogg"
77PACKAGECONFIG[vaapi] = "--enable-vaapi,--disable-vaapi,libva"
78PACKAGECONFIG[vdpau] = "--enable-vdpau,--disable-vdpau,libvdpau"
79PACKAGECONFIG[vpx] = "--enable-libvpx,--disable-libvpx,libvpx"
80PACKAGECONFIG[x264] = "--enable-libx264,--disable-libx264,x264"
81PACKAGECONFIG[x265] = "--enable-libx265,--disable-libx265,x265"
82PACKAGECONFIG[xcb] = "--enable-libxcb,--disable-libxcb,libxcb"
83PACKAGECONFIG[xv] = "--enable-outdev=xv,--disable-outdev=xv,libxv"
84PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
85
Andrew Geissler9b4d8b02021-02-19 12:26:16 -060086# other configuration options
87PACKAGECONFIG[mips32r2] = ",--disable-mipsdsp --disable-mipsdspr2"
88PACKAGECONFIG[pic] = "--enable-pic"
89PACKAGECONFIG[pthreads] = "--enable-pthreads,--disable-pthreads"
90PACKAGECONFIG[shared] = "--enable-shared"
91PACKAGECONFIG[strip] = ",--disable-stripping"
92
Andrew Geissler82c905d2020-04-13 13:39:40 -050093# Check codecs that require --enable-nonfree
94USE_NONFREE = "${@bb.utils.contains_any('PACKAGECONFIG', [ 'openssl' ], 'yes', '', d)}"
95
96def cpu(d):
97 for arg in (d.getVar('TUNE_CCARGS') or '').split():
98 if arg.startswith('-mcpu='):
99 return arg[6:]
100 return 'generic'
101
102EXTRA_OECONF = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500103 ${@bb.utils.contains('USE_NONFREE', 'yes', '--enable-nonfree', '', d)} \
104 \
105 --cross-prefix=${TARGET_PREFIX} \
106 \
107 --ld="${CCLD}" \
108 --cc="${CC}" \
109 --cxx="${CXX}" \
110 --arch=${TARGET_ARCH} \
111 --target-os="linux" \
112 --enable-cross-compile \
113 --extra-cflags="${CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
114 --extra-ldflags="${LDFLAGS}" \
115 --sysroot="${STAGING_DIR_TARGET}" \
116 ${EXTRA_FFCONF} \
117 --libdir=${libdir} \
118 --shlibdir=${libdir} \
119 --datadir=${datadir}/ffmpeg \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500120 --cpu=${@cpu(d)} \
121 --pkg-config=pkg-config \
122"
123
124EXTRA_OECONF_append_linux-gnux32 = " --disable-asm"
125# gold crashes on x86, another solution is to --disable-asm but thats more hacky
126# ld.gold: internal error in relocate_section, at ../../gold/i386.cc:3684
127
128LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
129
130EXTRA_OEMAKE = "V=1"
131
132do_configure() {
133 ${S}/configure ${EXTRA_OECONF}
134}
135
Andrew Geissler09209ee2020-12-13 08:44:15 -0600136# patch out build host paths for reproducibility
137do_compile_prepend_class-target() {
138 sed -i -e "s,${WORKDIR},,g" ${B}/config.h
139}
140
Andrew Geissler82c905d2020-04-13 13:39:40 -0500141PACKAGES =+ "libavcodec \
142 libavdevice \
143 libavfilter \
144 libavformat \
145 libavresample \
146 libavutil \
147 libpostproc \
148 libswresample \
149 libswscale"
150
151FILES_libavcodec = "${libdir}/libavcodec${SOLIBS}"
152FILES_libavdevice = "${libdir}/libavdevice${SOLIBS}"
153FILES_libavfilter = "${libdir}/libavfilter${SOLIBS}"
154FILES_libavformat = "${libdir}/libavformat${SOLIBS}"
155FILES_libavresample = "${libdir}/libavresample${SOLIBS}"
156FILES_libavutil = "${libdir}/libavutil${SOLIBS}"
157FILES_libpostproc = "${libdir}/libpostproc${SOLIBS}"
158FILES_libswresample = "${libdir}/libswresample${SOLIBS}"
159FILES_libswscale = "${libdir}/libswscale${SOLIBS}"
160
161# ffmpeg disables PIC on some platforms (e.g. x86-32)
162INSANE_SKIP_${MLPREFIX}libavcodec = "textrel"
163INSANE_SKIP_${MLPREFIX}libavdevice = "textrel"
164INSANE_SKIP_${MLPREFIX}libavfilter = "textrel"
165INSANE_SKIP_${MLPREFIX}libavformat = "textrel"
166INSANE_SKIP_${MLPREFIX}libavutil = "textrel"
167INSANE_SKIP_${MLPREFIX}libavresample = "textrel"
168INSANE_SKIP_${MLPREFIX}libswscale = "textrel"
169INSANE_SKIP_${MLPREFIX}libswresample = "textrel"
170INSANE_SKIP_${MLPREFIX}libpostproc = "textrel"