Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "The ssl.match_hostname() function from Python 3.4" |
| 2 | DESCRIPTION = "The Secure Sockets layer is only actually secure if you check the hostname in the \ |
| 3 | certificate returned by the server to which you are connecting, and verify that it matches to hostname \ |
| 4 | that you are trying to reach. But the matching logic, defined in RFC2818, can be a bit tricky to implement \ |
| 5 | on your own. So the ssl package in the Standard Library of Python 3.2 and greater now includes a \ |
| 6 | match_hostname() function for performing this check instead of requiring every application to \ |
| 7 | implement the check separately. This backport brings match_hostname() to users of earlier versions of Python" |
| 8 | |
| 9 | LICENSE = "GPLv2" |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://PKG-INFO;md5=b2adbe8bfdeb625c9a01afd9aaa66619" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 12 | SRC_URI[md5sum] = "32d2f593af01a046bec3d2f5181a420a" |
| 13 | SRC_URI[sha256sum] = "bb82e60f9fbf4c080eabd957c39f0641f0fc247d9a16e31e26d594d8f42b9fd2" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | |
| 15 | PYPI_PACKAGE = "backports.ssl_match_hostname" |
| 16 | inherit pypi setuptools |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 17 | |
| 18 | RDEPENDS_${PN} += "${PYTHON_PN}-pkgutil" |