blob: b89d7d2c8b310180f1513cee0ed2a6e0f2fc9843 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT & AFL-2.1 | GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \
Brad Bishopc1d34332019-09-09 14:56:00 -04006 file://dbus-gmain/COPYING;md5=99fece6728a80737c8fd3e7c734c17c4 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
8
9SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
10"
11
Brad Bishope42b3e32020-01-15 22:08:42 -050012SRC_URI[md5sum] = "c8739234fca9fba26368d1a337abe830"
13SRC_URI[sha256sum] = "b10206ba3dd641e4e46411ab91471c88e0eec1749860e4285193ee68df84ac31"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014S = "${WORKDIR}/dbus-python-${PV}"
15
16inherit distutils-base autotools pkgconfig
17
18# documentation needs python-sphinx, which is not in oe-core or meta-python for now
19# change to use PACKAGECONFIG when python-sphinx is added to oe-core or meta-python
20EXTRA_OECONF += "--disable-documentation"
21
22export STAGING_LIBDIR
23export STAGING_INCDIR
24
25RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
26
27FILES_${PN}-dev += "${libdir}/pkgconfig"
28
29do_install_append() {
30 # Remove files that clash with python3-dbus; their content is same
31 rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
32}