blob: 97313d7e2497879764e7d3b59f36c76eed546fcb [file] [log] [blame]
Brad Bishop96ff1982019-08-19 13:50:42 -04001SUMMARY = "Fortran Hello World"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5DEPENDS = "libgfortran"
6
7SRC_URI = "file://hello.f95"
8
9# These set flags that Fortran doesn't support
10SECURITY_CFLAGS = ""
11SECURITY_LDFLAGS = ""
12
13do_compile() {
14 ${HOST_PREFIX}gfortran ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS} ${LDFLAGS} ${WORKDIR}/hello.f95 -o ${B}/fortran-hello
15}
16
17do_install() {
18 install -d ${D}${bindir}
19 install ${B}/fortran-hello ${D}${bindir}
20}
21
22python () {
23 if not d.getVar("FORTRAN"):
24 raise bb.parse.SkipRecipe("Fortran isn't enabled")
25}