blob: 9b95721a4ecd84c6bc40461a73dc14e1abf45a35 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Tools to manipulate UEFI variables"
2DESCRIPTION = "efivar provides a simple command line interface to the UEFI variable facility"
3HOMEPAGE = "https://github.com/rhboot/efivar"
4
5LICENSE = "LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6626bb1e20189cfa95f2c508ba286393"
7
8COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
9
10SRC_URI = "git://github.com/rhinstaller/efivar.git \
11 file://no-werror.patch"
12SRCREV = "c1d6b10e1ed4ba2be07f385eae5bceb694478a10"
13
14S = "${WORKDIR}/git"
15
16inherit pkgconfig
17
18export CCLD_FOR_BUILD = "${BUILD_CCLD}"
19
20# Upstream uses --add-needed in gcc.specs which gold doesn't support, so
21# enforce BFD.
22LDFLAGS += "-fuse-ld=bfd"
23
24do_compile_prepend() {
25 # Remove when https://github.com/rhboot/efivar/issues/130 is fixed
Brad Bishop96ff1982019-08-19 13:50:42 -040026 oe_runmake \
27 CFLAGS="${BUILD_CFLAGS}" \
28 LDFLAGS="${BUILD_LDFLAGS}" \
29 -C src makeguids
Brad Bishop15ae2502019-06-18 21:44:24 -040030}
31
32do_install() {
33 oe_runmake install DESTDIR=${D}
34}
35
36BBCLASSEXTEND = "native"
37
38RRECOMMENDS_${PN}_class-target = "kernel-module-efivarfs"
39
40CLEANBROKEN = "1"