blob: 77bc31af7e2232ec7823c426654a3a0bc5966053 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Interface for user-level network packet capture"
2DESCRIPTION = "Libpcap provides a portable framework for low-level network \
3monitoring. Libpcap can provide network statistics collection, \
4security monitoring and network debugging."
5HOMEPAGE = "http://www.tcpdump.org/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=53067&atid=469577"
7SECTION = "libs/network"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb289217c160e2920d2e35bddc36453 \
10 file://pcap.h;beginline=1;endline=32;md5=39af3510e011f34b8872f120b1dc31d2"
11DEPENDS = "flex-native bison-native"
12
13SRC_URI = "https://www.tcpdump.org/release/${BP}.tar.gz \
14 file://0001-pcap-usb-linux.c-add-missing-limits.h-for-musl-syste.patch \
15 "
16SRC_URI[md5sum] = "dffd65cb14406ab9841f421732eb0f33"
17SRC_URI[sha256sum] = "2edb88808e5913fdaa8e9c1fcaf272e19b2485338742b5074b9fe44d68f37019"
18
Brad Bishop96ff1982019-08-19 13:50:42 -040019inherit autotools binconfig-disabled pkgconfig
Brad Bishop19323692019-04-05 15:28:33 -040020
21BINCONFIG = "${bindir}/pcap-config"
22
23# Explicitly disable dag support. We don't have recipe for it and if enabled here,
24# configure script poisons the include dirs with /usr/local/include even when the
25# support hasn't been detected.
26EXTRA_OECONF = " \
27 --with-pcap=linux \
28 --without-dag \
29 "
30EXTRA_AUTORECONF += "--exclude=aclocal"
31
Brad Bishop96ff1982019-08-19 13:50:42 -040032PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez5', '', d)} \
Brad Bishop19323692019-04-05 15:28:33 -040033 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
34"
35PACKAGECONFIG[bluez5] = "--enable-bluetooth,--disable-bluetooth,bluez5"
36PACKAGECONFIG[dbus] = "--enable-dbus,--disable-dbus,dbus"
37PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
38PACKAGECONFIG[libnl] = "--with-libnl,--without-libnl,libnl"
39
40do_configure_prepend () {
41 #remove hardcoded references to /usr/include
42 sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.ac
43}
44
45BBCLASSEXTEND = "native"