blob: c347daf5014f568cd45cc7eb2c867a5f0bbb28f2 [file] [log] [blame]
Brad Bishop00111322018-04-01 22:23:53 -04001SUMMARY = "inittab configuration for BusyBox"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
4
5SRC_URI = "file://inittab"
6
7S = "${WORKDIR}"
8
9INHIBIT_DEFAULT_DEPS = "1"
10
11do_compile() {
12 :
13}
14
15do_install() {
16 install -d ${D}${sysconfdir}
17 install -D -m 0644 ${WORKDIR}/inittab ${D}${sysconfdir}/inittab
18 tmp="${SERIAL_CONSOLES}"
19 for i in $tmp
20 do
21 j=`echo ${i} | sed s/\;/\ /g`
22 id=`echo ${i} | sed -e 's/^.*;//' -e 's/;.*//'`
23 echo "$id::respawn:${base_sbindir}/getty ${j}" >> ${D}${sysconfdir}/inittab
24 done
25}
26
27# SERIAL_CONSOLES is generally defined by the MACHINE .conf.
28# Set PACKAGE_ARCH appropriately.
29PACKAGE_ARCH = "${MACHINE_ARCH}"
30
31FILES_${PN} = "${sysconfdir}/inittab"
32CONFFILES_${PN} = "${sysconfdir}/inittab"
Brad Bishop15ae2502019-06-18 21:44:24 -040033
34RCONFLICTS_${PN} = "sysvinit-inittab"