blob: bd0989e88555a59761baa4df967aa8d66cf85425 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "ifupdown: basic ifup and ifdown used by initscripts"
2DESCRIPTION = "High level tools to configure network interfaces \
3This package provides the tools ifup and ifdown which may be used to \
4configure (or, respectively, deconfigure) network interfaces, based on \
5the file /etc/network/interfaces."
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
8
Brad Bishop316dfdd2018-06-25 12:45:53 -04009SRC_URI = "git://salsa.debian.org/debian/ifupdown.git;protocol=https \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050010 file://defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch \
11 file://inet-6-.defn-fix-inverted-checks-for-loopback.patch \
12 file://99_network \
Brad Bishop96ff1982019-08-19 13:50:42 -040013 file://0001-Define-FNM_EXTMATCH-for-musl.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014 "
Brad Bishop96ff1982019-08-19 13:50:42 -040015SRCREV = "ab5a0f464e53e172316a5ca8b5dcdc49e8848999"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050016
17S = "${WORKDIR}/git"
18
19
20inherit update-alternatives
21
22do_compile () {
23 chmod a+rx *.pl *.sh
24 oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
25}
26
27do_install () {
28 install -d ${D}${mandir}/man8 \
29 ${D}${mandir}/man5 \
30 ${D}${base_sbindir}
31
32 # If volatiles are used, then we'll also need /run/network there too.
33 install -d ${D}/etc/default/volatiles
34 install -m 0644 ${WORKDIR}/99_network ${D}/etc/default/volatiles
35
36 install -m 0755 ifup ${D}${base_sbindir}/
37 ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
38 install -m 0644 ifup.8 ${D}${mandir}/man8
39 install -m 0644 interfaces.5 ${D}${mandir}/man5
40 cd ${D}${mandir}/man8 && ln -s ifup.8 ifdown.8
41}
42
43ALTERNATIVE_PRIORITY = "100"
44ALTERNATIVE_${PN} = "ifup ifdown"
45
46ALTERNATIVE_LINK_NAME[ifup] = "${base_sbindir}/ifup"
47ALTERNATIVE_LINK_NAME[ifdown] = "${base_sbindir}/ifdown"