blob: 7946e20c575f6e6fe94e40aef913204b3fb0d01b [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU Project parser generator (yacc replacement)"
2DESCRIPTION = "Bison is a general-purpose parser generator that converts an annotated context-free grammar into \
3an LALR(1) or GLR parser for that grammar. Bison is upward compatible with Yacc: all properly-written Yacc \
4grammars ought to work with Bison with no change. Anyone familiar with Yacc should be able to use Bison with \
5little trouble."
6HOMEPAGE = "http://www.gnu.org/software/bison/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9SECTION = "devel"
10DEPENDS = "bison-native flex-native"
11
12SRC_URI = "${GNU_MIRROR}/bison/bison-${PV}.tar.xz \
13 file://dont-depend-on-help2man.patch.patch \
14 file://add-with-bisonlocaledir.patch \
15"
16
17# No point in hardcoding path to m4, just use PATH
18EXTRA_OECONF += "M4=m4"
19
Brad Bishop96ff1982019-08-19 13:50:42 -040020SRC_URI[md5sum] = "201286a573b12da109df96282fe4ff4a"
21SRC_URI[sha256sum] = "27159ac5ebf736dffd5636fd2cd625767c9e437de65baa63cb0de83570bd820d"
Brad Bishopc342db32019-05-15 21:57:59 -040022
23inherit autotools gettext texinfo
24
25# The automatic m4 path detection gets confused, so force the right value
26acpaths = "-I ${S}/m4"
27
28do_compile_prepend() {
29 for i in mfcalc calc++ rpcalc; do mkdir -p ${B}/examples/$i; done
30}
31
32do_install_append_class-native() {
33 create_wrapper ${D}/${bindir}/bison \
34 BISON_PKGDATADIR=${STAGING_DATADIR_NATIVE}/bison
35}
36do_install_append_class-nativesdk() {
37 create_wrapper ${D}/${bindir}/bison \
38 BISON_PKGDATADIR=${datadir}/bison
39}
40BBCLASSEXTEND = "native nativesdk"