blob: 6452c8d99f72a406b1cb01fd3cd7c9fc772e4d09 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Document type definitions for verification of XML data files"
2DESCRIPTION = "Document type definitions for verification of XML data \
3files against the DocBook rule set, it ships with the latest DocBook 4.5 \
4XML DTD, as well as a selected set of legacy DTDs for use with older \
5documents, including 4.0, 4.1.2, 4.2, 4.3 and 4.4"
6HOMEPAGE = "http://www.docbook.org/xml/"
7
8LICENSE = "OASIS"
9LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE-OASIS;md5=c608985dd5f7f215e669e7639a0b1d2e"
10
11# Note: the upstream sources are not distributed with a license file.
12# LICENSE-OASIS is included as a "patch" to workaround this. When
13# upgrading this recipe, please verify whether this is still needed.
Patrick Williamsc0f7c042017-02-23 20:41:17 -060014SRC_URI = "http://snapshot.debian.org/archive/debian/20160728T043443Z/pool/main/d/docbook-xml/docbook-xml_${PV}.orig.tar.gz \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015 file://LICENSE-OASIS \
16 file://docbook-xml-update-catalog.xml.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017"
18
19SRC_URI[md5sum] = "487b4d44e15cffb1f4048af23f98208e"
20SRC_URI[sha256sum] = "b0f8edcf697f5318e63dd98c9a931f3fee167af0805ba441db372e0f17b2a44f"
21
Patrick Williamsc0f7c042017-02-23 20:41:17 -060022UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/docbook-xml/"
23
Brad Bishop19323692019-04-05 15:28:33 -040024S = "${WORKDIR}/docbook-xml-4.5.c31424"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025
26inherit allarch
27BBCLASSEXTEND = "native"
28
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029do_configure (){
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030 :
31}
32
33do_compile (){
34 :
35}
36
37do_install () {
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038 install -d ${D}${sysconfdir}/xml/
Brad Bishop19323692019-04-05 15:28:33 -040039 xmlcatalog --create --noout ${D}${sysconfdir}/xml/docbook-xml.xml
40
41 for DTDVERSION in 4.0 4.1.2 4.2 4.3 4.4 4.5; do
42 DEST=${datadir}/xml/docbook/schema/dtd/$DTDVERSION
43 install -d -m 755 ${D}$DEST
44 cp -v -R docbook-$DTDVERSION/* ${D}$DEST
45 xmlcatalog --verbose --noout --add nextCatalog unused file://$DEST/catalog.xml ${D}${sysconfdir}/xml/docbook-xml.xml
46 done
Patrick Williamsc124f4f2015-09-15 14:41:29 -050047}
48
Brad Bishop19323692019-04-05 15:28:33 -040049XMLCATALOGS = "${sysconfdir}/xml/docbook-xml.xml"
50inherit xmlcatalog
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051
52FILES_${PN} = "${datadir}/* ${sysconfdir}/xml/docbook-xml.xml"