blob: f1236e8ac8247a8bc086bfd6f1ecf5eeadb3bb1e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Ninja is a small build system with a focus on speed."
2HOMEPAGE = "http://martine.github.com/ninja/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
5
6DEPENDS = "re2c-native ninja-native"
7
8SRCREV = "b25c08bda4949192c69cea4cee057887341a2ffc"
9
10SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release \
11 file://fix-musl.patch \
12"
13UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
14
15S = "${WORKDIR}/git"
16
17do_configure[noexec] = "1"
18
19do_compile_class-native() {
Brad Bishop96ff1982019-08-19 13:50:42 -040020 python3 ./configure.py --bootstrap
Brad Bishop19323692019-04-05 15:28:33 -040021}
22
23do_compile() {
Brad Bishop96ff1982019-08-19 13:50:42 -040024 python3 ./configure.py
Brad Bishop19323692019-04-05 15:28:33 -040025 ninja
26}
27
28do_install() {
29 install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
30}
31
32BBCLASSEXTEND = "native nativesdk"