blob: f1545dade601c2482ff9343bfc3fed9aaf60cb03 [file] [log] [blame]
Brad Bishop15ae2502019-06-18 21:44:24 -04001SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=37bb53a08e6beaea0c90e7821d731284"
5
6SRC_URI = "${SOURCEFORGE_MIRROR}/scons/scons-${PV}.tar.gz"
Brad Bishop96ff1982019-08-19 13:50:42 -04007SRC_URI[md5sum] = "e2fe9d16f81b0285b969238af4b552ff"
8SRC_URI[sha256sum] = "f3f548d738d4a2179123ecd744271ec413b2d55735ea7625a59b1b59e6cd132f"
Brad Bishop15ae2502019-06-18 21:44:24 -04009
10S = "${WORKDIR}/scons-${PV}"
11
12UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
13UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
14
15inherit setuptools3
16
17do_install_prepend() {
18 sed -i -e "1s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/script/*
19}
20
21RDEPENDS_${PN} = "\
22 python3-core \
23 python3-fcntl \
24 python3-io \
25 python3-json \
26 python3-shell \
27 python3-pickle \
28 python3-pprint \
29 "