blob: 3d0f3e688db3dc22200a456096c9402345173b1c [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Subversion (svn) version control system client"
2HOMEPAGE = "http://subversion.apache.org"
3SECTION = "console/network"
4LICENSE = "Apache-2 & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6487ae7094d359fa90fb9c4096e52e2b"
6
7DEPENDS = "apr-util serf sqlite3 file lz4"
8DEPENDS_append_class-native = " file-replacement-native"
9
10SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
11 file://disable_macos.patch \
12 file://0001-Fix-libtool-name-in-configure.ac.patch \
13 file://serfmacro.patch \
14 file://subversion-1.12.0-apr_1.7.0_fix-1.patch \
15 "
16
17SRC_URI[md5sum] = "be4f5c0b1b38a5d82bd6d16a16ff1346"
18SRC_URI[sha256sum] = "7fae7c73d8a007c107c0ae5eb372bc0bb013dbfe966fcd5c59cd5a195a5e2edf"
19
20inherit autotools pkgconfig gettext
21
Brad Bishop96ff1982019-08-19 13:50:42 -040022CVE_PRODUCT = "apache:subversion"
23
Brad Bishopc342db32019-05-15 21:57:59 -040024PACKAGECONFIG ?= ""
25
26PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl"
27PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring"
28
29EXTRA_OECONF = " \
30 --with-apr=${STAGING_BINDIR_CROSS} \
31 --with-apr-util=${STAGING_BINDIR_CROSS} \
32 --without-apxs \
33 --without-berkeley-db \
34 --without-swig \
35 --disable-keychain \
36 --with-utf8proc=internal \
37 ac_cv_path_RUBY=none \
38"
39
40acpaths = "-I build/ -I build/ac-macros/"
41
42CPPFLAGS += "-P"
43BUILD_CPPFLAGS += "-P"
44
45do_configure_prepend () {
46 rm -f ${S}/libtool
47 rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4
48 rm -f ${S}/aclocal.m4
49 sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4
50}
51
52#| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
53#| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it
54#| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
55#| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed
56#| make: *** [install-serf-lib] Error 1
57PARALLEL_MAKEINST = ""
58
59RDEPENDS_${PN} = "serf"
60
61BBCLASSEXTEND = "native"