blob: fce0329534153a93bcc22c16f6d3033da546ba62 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Documentation generator for glib-based software"
2DESCRIPTION = "Gtk-doc is a set of scripts that extract specially formatted comments \
3 from glib-based software and produce a set of html documentation files from them"
4HOMEPAGE = "http://www.gtk.org/gtk-doc/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8inherit gnomebase
9
10# Configure the scripts correctly (and build their dependencies) only if they are actually
11# going to be used; otheriwse we need only the m4/makefile includes from the gtk-doc tarball.
12PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "api-documentation", "working-scripts", "", d)}"
13
14# This will cause target gtk-doc to hardcode paths of native dependencies
15# into its scripts. This means that target gtk-doc package is broken;
16# hopefully no one minds because its scripts are not used for anything during build
17# and shouldn't be used on targets.
Brad Bishop15ae2502019-06-18 21:44:24 -040018PACKAGECONFIG[working-scripts] = ",,libxslt-native xmlto-native python3-six python3-pygments"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,glib-2.0"
20
Brad Bishop15ae2502019-06-18 21:44:24 -040021SRC_URI[archive.md5sum] = "1045ba29ca0693ced2045523407aae4c"
22SRC_URI[archive.sha256sum] = "a4f6448eb838ccd30d76a33b1fd095f81aea361f03b12c7b23df181d21b7069e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
24 file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
25 file://conditionaltests.patch \
26 file://no-clobber.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040027 file://0001-highlight.py-correctly-set-permissions-on-file-to-be.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028 "
29SRC_URI_append_class-native = " file://pkg-config-native.patch"
30
31BBCLASSEXTEND = "native nativesdk"
32
33# Do not check for XML catalogs when building because that
34# information is not used for anything during build. Recipe
35# dependencies make sure we have all the right bits.
36do_configure_prepend() {
37 sed -i -e 's,^JH_CHECK_XML_CATALOG.*,,' ${S}/configure.ac
38}
39
40FILES_${PN} += "${datadir}/sgml"
41FILES_${PN}-dev += "${libdir}/cmake"
42FILES_${PN}-doc = ""
43
44SYSROOT_PREPROCESS_FUNCS_append_class-native = " gtkdoc_makefiles_sysroot_preprocess"
45gtkdoc_makefiles_sysroot_preprocess() {
46 # Patch the gtk-doc makefiles so that the qemu wrapper is used to run transient binaries
47 # instead of libtool wrapper or running them directly
48 sed -i \
49 -e "s|GTKDOC_RUN =.*|GTKDOC_RUN = \$(top_builddir)/gtkdoc-qemuwrapper|" \
50 ${SYSROOT_DESTDIR}${datadir}/gtk-doc/data/gtk-doc*make
51}