blob: b179a0ed473078d77ba84e14ae065e531f2312f3 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8SECTION = "libs"
9
10LICENSE = "FreeType | GPLv2+"
11LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=4af6221506f202774ef74f64932878a1 \
12 file://docs/FTL.TXT;md5=9f37b4e6afa3fef9dba8932b16bd3f97 \
13 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
14
Brad Bishop96ff1982019-08-19 13:50:42 -040015SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/${BPN}/${BP}.tar.xz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016 file://use-right-libtool.patch \
17 "
Brad Bishop96ff1982019-08-19 13:50:42 -040018SRC_URI[md5sum] = "bd42e75127f8431923679480efb5ba8f"
19SRC_URI[sha256sum] = "16dbfa488a21fe827dc27eaf708f42f7aa3bb997d745d31a19781628c36ba26f"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021UPSTREAM_CHECK_REGEX = "freetype-(?P<pver>\d+(\.\d+)+)"
22
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023inherit autotools pkgconfig multilib_header
24
25# Adapt autotools to work with the minimal autoconf usage in freetype
26AUTOTOOLS_SCRIPT_PATH = "${S}/builds/unix"
27CONFIGURE_SCRIPT = "${S}/configure"
28EXTRA_AUTORECONF += "--exclude=autoheader --exclude=automake"
29
30PACKAGECONFIG ??= "zlib"
31
32PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
33# harfbuzz results in a circular dependency so enabling is non-trivial
34PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
35PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
36PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
37PACKAGECONFIG[freetypeconfig] = "--enable-freetype-config=yes,--enable-freetype-config=no,"
38
39EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
40
41TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
42
43do_install_append() {
44 oe_multilib_header freetype2/freetype/config/ftconfig.h
45}
46
47BBCLASSEXTEND = "native nativesdk"