blob: fc013d75c357d222be53add8596cd1dbee7d8f70 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "libva-utils is a collection of utilities from libva project"
2
3DESCRIPTION = "libva-utils is a collection of utilities \
4and examples to exercise VA-API in accordance with the libva \
5project.VA-API is an open-source library and API specification, \
6which provides access to graphics hardware acceleration capabilities \
7for video processing. It consists of a main library and driver-specific \
8acceleration backends for each supported hardware vendor"
9
10HOMEPAGE = "https://01.org/linuxmedia/vaapi"
11BUGTRACKER = "https://github.com/intel/libva-utils/issues"
12
13SECTION = "x11"
14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://COPYING;md5=b148fc8adf19dc9aec17cf9cd29a9a5e"
16
17SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2 \
18 file://0001-Build-sfcsample-only-when-X11-backend-is-enabled.patch \
19 "
20
Brad Bishop96ff1982019-08-19 13:50:42 -040021SRC_URI[md5sum] = "c1fada26c286654859eff33b2562cb79"
22SRC_URI[sha256sum] = "9238c9d5110d60f935683390b8383fdac3507346384cd5f117a23c6db1d72a17"
Brad Bishop19323692019-04-05 15:28:33 -040023
24UPSTREAM_CHECK_URI = "https://github.com/intel/libva-utils/releases"
25
26DEPENDS = "libva"
27
28inherit autotools pkgconfig distro_features_check
29
30# depends on libva which requires opengl
31REQUIRED_DISTRO_FEATURES = "opengl"
32
33PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
34PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
35PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"