blob: d2041d7d4c7483bff27843bf65eb31638fe93d9a [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Collection of Vulkan examples"
2LICENSE = "MIT"
3DEPENDS = "zlib"
4
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=dcf473723faabf17baa9b5f2207599d0 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006 file://examples/triangle/triangle.cpp;endline=12;md5=bccd1bf9cadd9e10086cf7872157e4fa"
7
8SRCREV_glm = "01f9ab5b6d21e5062ac0f6e0f205c7fa2ca9d769"
9SRCREV_gli = "8e43030b3e12bb58a4663d85adc5c752f89099c0"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
11SRC_URI = "git://github.com/SaschaWillems/Vulkan.git \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012 git://github.com/g-truc/glm;destsuffix=git/external/glm;name=glm \
13 git://github.com/g-truc/gli;destsuffix=git/external/gli;name=gli \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014 file://0001-Don-t-build-demos-with-questionably-licensed-data.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016UPSTREAM_CHECK_COMMITS = "1"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017SRCREV = "ae0b59c6e2e8630a2ae26f4a0b7a72cbe7547948"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
19S = "${WORKDIR}/git"
20
21REQUIRED_DISTRO_FEATURES = 'vulkan'
22
23inherit cmake distro_features_check
Brad Bishop96ff1982019-08-19 13:50:42 -040024DEPENDS = "vulkan-loader assimp"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025
26do_install_append () {
27 # Remove assets that have uncertain licenses
28 rm ${D}${datadir}/vulkan-demos/models/armor/* \
29 ${D}${datadir}/vulkan-demos/models/sibenik/* \
30 ${D}${datadir}/vulkan-demos/models/vulkanscene* \
31 ${D}${datadir}/vulkan-demos/models/plants.dae \
32 ${D}${datadir}/vulkan-demos/textures/texturearray_plants*
33
34 mv ${D}${bindir}/screenshot ${D}${bindir}/vulkan-screenshot
35}
36
37EXTRA_OECMAKE = "-DRESOURCE_INSTALL_DIR=${datadir}/vulkan-demos"
38
39ANY_OF_DISTRO_FEATURES = "x11 wayland"
40
41# Can only pick one of [wayland,xcb]
42PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'xcb' ,d)}"
43PACKAGECONFIG[wayland] = "-DUSE_WAYLAND_WSI=ON, -DUSE_WAYLAND_WSI=OFF, wayland"
44PACKAGECONFIG[xcb] = ",,libxcb"