blob: 02156ad75b450f61d59faf62dca470137d340125 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
Brad Bishopf3fd2882019-06-21 08:06:37 -040016SRC_URI[md5sum] = "316753e35d3906d042c74230612eab9f"
17SRC_URI[sha256sum] = "690daec8fea63526c07620c90e6f3f10aae34e94b6db6e30906173480721901f"
Brad Bishop19323692019-04-05 15:28:33 -040018
19SECTION = "x11/libs"
Brad Bishop96ff1982019-08-19 13:50:42 -040020DEPENDS = "util-macros libxslt-native"
Brad Bishop19323692019-04-05 15:28:33 -040021
22EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
23
24FILES_${PN} += "${datadir}/X11/xkb"
25
26inherit autotools pkgconfig gettext
27
28do_install_append () {
29 install -d ${D}${datadir}/X11/xkb/compiled
30 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
31}