blob: c1f4acdb038d37d8ea237dd9a445359aea8dea3e [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Advanced tools for certain ALSA sound card drivers"
2HOMEPAGE = "http://www.alsa-project.org"
3BUGTRACKER = "http://alsa-project.org/main/index.php/Bug_Tracking"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & LGPLv2+"
6DEPENDS = "alsa-lib"
7
8LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
9 file://ld10k1/COPYING.LIB;md5=a916467b91076e631dd8edb7424769c7 \
10 "
11
12SRC_URI = "https://www.alsa-project.org/files/pub/tools/${BP}.tar.bz2"
13
14SRC_URI[md5sum] = "475bdf6457bcf55c8c895d653ee56a54"
15SRC_URI[sha256sum] = "a0243328a8f6f691a3055c484fd8d3326393096325e93743b246029d327c4ef6"
16
17inherit autotools-brokensep pkgconfig
18# brokensep as as10k1 (and probably more) fail out of tree
19CLEANBROKEN = "1"
20
21# Here we use PACKAGECONFIG options to pick which directories we configure/build.
22# Remember on upgrades to check that no new tools have been added.
23PACKAGECONFIG ??= "as10k1 hdajacksensetest hda-verb hdsploader ld10k1 mixartloader pcxhrloader \
24 sb16_csp seq--sbiload sscape_ctl us428control usx2yloader vxloader \
Brad Bishop19323692019-04-05 15:28:33 -040025 ${@bb.utils.contains_any('DISTRO_FEATURES', '${GTK3DISTROFEATURES}', 'hdajackretask', '', d)} \
26 "
27
28PACKAGECONFIG[as10k1] = ""
29PACKAGECONFIG[echomixer] = ",,gtk+"
30PACKAGECONFIG[envy24control] = ",,gtk+"
31PACKAGECONFIG[hda-verb] = ""
32PACKAGECONFIG[hdajackretask] = ",,gtk+3"
33PACKAGECONFIG[hdajacksensetest] = ",,glib-2.0"
34PACKAGECONFIG[hdspconf] = ",,fltk"
35PACKAGECONFIG[hdsploader] = ""
36PACKAGECONFIG[hdspmixer] = ",,fltk"
37PACKAGECONFIG[ld10k1] = ""
38PACKAGECONFIG[mixartloader] = ""
39PACKAGECONFIG[pcxhrloader] = ""
40PACKAGECONFIG[qlo10k1] = ",,qt-x11-free"
41PACKAGECONFIG[rmedigicontrol] = ",,gtk+"
42PACKAGECONFIG[sb16_csp] = ""
43PACKAGECONFIG[seq--sbiload] = ""
44PACKAGECONFIG[sscape_ctl] = ""
45PACKAGECONFIG[us428control] = ""
46PACKAGECONFIG[usx2yloader] = ""
47PACKAGECONFIG[vxloader] = ""
48
49# At the time of writing pyalsa is not packaged for OE, so this is not expected
50# to work.
51PACKAGECONFIG[hwmixvolume] = ",,,python-core python-pygobject pyalsa"
52
53python do_configure() {
54 for subdir in d.getVar("PACKAGECONFIG").split():
55 subdir = subdir.replace("--", "/")
56 bb.note("Configuring %s" % subdir)
57 dd = d.createCopy()
58 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
59 bb.build.exec_func("autotools_do_configure", dd)
60}
61
62python do_compile() {
63 for subdir in d.getVar("PACKAGECONFIG").split():
64 subdir = subdir.replace("--", "/")
65 bb.note("Compiling %s" % subdir)
66 dd = d.createCopy()
67 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
68 bb.build.exec_func("autotools_do_compile", dd)
69}
70
71python do_install() {
72 for subdir in d.getVar("PACKAGECONFIG").split():
73 subdir = subdir.replace("--", "/")
74 bb.note("Installing %s" % subdir)
75 dd = d.createCopy()
76 dd.setVar("S", os.path.join(d.getVar("S"), subdir))
77 bb.build.exec_func("autotools_do_install", dd)
78
79 # Just remove bash-needing init script that isn't installed as an init script
80 try:
81 os.remove(oe.path.join(d.getVar("D"), d.getVar("sbindir"), "ld10k1d"))
82 except:
83 pass
84}
85
86FILES_${PN} += "${datadir}"