blob: fe3b1105c4f7604035bde70a916eba8f5d4ecf91 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Help browser for the GNOME desktop"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
5"
6
7inherit gnomebase itstool autotools-brokensep gsettings gettext gtk-doc features_check mime-xdg
8
9# for webkitgtk
10REQUIRED_DISTRO_FEATURES = "x11"
11
Patrick Williams975a06f2022-10-21 14:42:47 -050012SRC_URI[archive.sha256sum] = "a2c5fd0787a9089c722cc66bd0f85cdf7088d870e7b6cc85799f8e5bff9eac4b"
Andrew Geissler595f6302022-01-24 19:11:47 +000013
14DEPENDS += " \
15 libxml2-native \
16 glib-2.0-native \
17 gtk+3 \
18 appstream-glib \
19 libxslt \
20 sqlite3 \
Patrick Williamsde0582f2022-04-08 10:23:27 -050021 libhandy \
Andrew Geissler595f6302022-01-24 19:11:47 +000022 webkitgtk \
23 yelp-xsl \
24"
25PACKAGECONFIG ?= ""
26
27# Enable if soup3 is enabled in webkit recipe
28PACKAGECONFIG[soup3] = ",--with-webkit2gtk-4-0,"
29
30do_configure:prepend() {
31 export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
32}
33
34FILES:${PN} += " \
35 ${datadir}/metainfo \
36 ${datadir}/yelp-xsl \
37"
38
39RDEPENDS:${PN} += "yelp-xsl"