blob: 322b58477dbc3626b72e172a1f4a77e265ad23f2 [file] [log] [blame]
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -05001SUMMARY = "A subproject of Apache NiFi to collect data where it originates."
2DESCRIPTION = "MiNiFi--a subproject of Apache NiFi--is a complementary \
3data collection approach that supplements the core tenets of NiFi in dataflow \
4management, focusing on the collection of data at the source of its creation."
5HOMEPAGE = "https://nifi.apache.org/minifi/index.html"
6SECTION = "console/network"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=f9534eb5f4ab800b573a37bffc62f3a7"
9
Andrew Geissler4b7c1152020-11-30 19:55:29 -060010DEPENDS = "virtual/crypt expat flex python3 bison-native libxml2 nettle lz4"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050011RDEPENDS_${PN} = "python3-core"
12
13SRCREV = "aa42957a2e227df41510047cece3cd606dc1cb6a"
14SRC_URI = "git://github.com/apache/nifi-minifi-cpp.git \
Andrew Geisslera2681d92020-10-16 10:17:07 -050015 https://curl.haxx.se/download/curl-7.64.0.tar.bz2;name=curl;subdir=git/thirdparty \
16 https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/libressl-2.8.3.tar.gz;name=libressl;subdir=git/thirdparty \
17 ${DEBIAN_MIRROR}/main/o/ossp-uuid/ossp-uuid_1.6.2.orig.tar.gz;name=ossp-uuid;subdir=git/thirdparty \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050018 file://fix-minifi-compile.patch \
19 file://fix-libressl-compile.patch \
20 file://fix-libressl-avoid-BSWAP-assembly-for-ARM-v6.patch \
21 file://fix-osspuuid-compile.patch \
22 file://fix-osspuuid-cross-compile.patch \
23 file://fix-osspuuid-musl-compile.patch \
24 file://fix-rocksdb-cross-compile.patch \
25 file://remove_const_due_to_std_lock_guard.patch \
26 file://0001-Add-lxml2-to-linker-cmdline-of-xml-is-found.patch \
Andrew Geisslera2681d92020-10-16 10:17:07 -050027 file://0001-CMakeLists.txt-use-curl-local-source-tarball.patch \
28 file://0002-cmake-LibreSSL.cmake-use-libressl-local-source-tarba.patch \
29 file://0003-cmake-BundledOSSPUUID.cmake-use-ossp-uuid-local-sour.patch \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060030 file://0001-civetweb-CMakeLists.txt-do-not-search-gcc-ar-and-gcc.patch \
Andrew Geissler97771a32021-03-05 15:23:11 -060031 file://0001-cxxopts-Add-limits-header.patch \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050032 file://minifi.service \
33 file://systemd-volatile.conf \
34 file://sysvinit-volatile.conf \
35 "
Andrew Geisslera2681d92020-10-16 10:17:07 -050036
37SRC_URI[curl.md5sum] = "d0bcc586873cfef08b4b9594e5395a33"
38SRC_URI[curl.sha256sum] = "d573ba1c2d1cf9d8533fadcce480d778417964e8d04ccddcc76e591d544cf2eb"
39SRC_URI[libressl.md5sum] = "0f1127bd21b4aa8495a910379c2ad936"
40SRC_URI[libressl.sha256sum] = "9b640b13047182761a99ce3e4f000be9687566e0828b4a72709e9e6a3ef98477"
41SRC_URI[ossp-uuid.md5sum] = "5db0d43a9022a6ebbbc25337ae28942f"
42SRC_URI[ossp-uuid.sha256sum] = "11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0"
43
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050044S = "${WORKDIR}/git"
45
46inherit pkgconfig cmake systemd
47
48SYSTEMD_PACKAGES = "minifi-cpp"
49SYSTEMD_SERVICE_${PN} = "minifi.service"
50SYSTEMD_AUTO_ENABLE = "disable"
51
52OECMAKE_FIND_ROOT_PATH_MODE_PROGRAM = "BOTH"
53
54EXTRA_OECMAKE += " \
55 -DHOST_SYS=${HOST_SYS} -DBUILD_SYS=${BUILD_SYS} \
56 -DSKIP_TESTS=ON \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060057 -DGCC_AR=${STAGING_BINDIR_TOOLCHAIN}/${AR} \
58 -DGCC_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${RANLIB} \
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050059 "
60EXTRA_OECMAKE_append_toolchain-clang = " -DCMAKE_RANLIB=${STAGING_BINDIR_TOOLCHAIN}/${TARGET_PREFIX}llvm-ranlib"
61LDFLAGS_append_toolchain-clang = " -fuse-ld=lld"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060062
63# RV lld errors out:
64# riscv64-yoe-linux-ld.lld: error: init.c:(.text+0x0): relocation R_RISCV_ALIGN requires unimplemented linker relaxation; recompile with -mno-relax
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -050065LDFLAGS_remove_riscv32 = "-fuse-ld=lld"
Andrew Geissler4b7c1152020-11-30 19:55:29 -060066LDFLAGS_remove_riscv64 = "-fuse-ld=lld"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050067
68# There are endian issues when communicating with the x86 nifi on the the mips and the ppc machines.
69COMPATIBLE_MACHINE_mips = "(!.*mips).*"
70COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*"
71COMPATIBLE_MACHINE_powerpc = "(!.*ppc).*"
72
Andrew Geissler4b7c1152020-11-30 19:55:29 -060073TARGET_CFLAGS_append_riscv32 = " -fpic"
74TARGET_CXXFLAGS_append_riscv32 = " -fpic"
75TARGET_CFLAGS_append_riscv64 = " -fpic"
76TARGET_CXXFLAGS_append_riscv64 = " -fpic"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050077
Andrew Geisslera2681d92020-10-16 10:17:07 -050078do_install[cleandirs] += "${WORKDIR}/minifi-install"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060079PSEUDO_CONSIDER_PATHS .= ",${WORKDIR}/minifi-install"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050080
81do_install() {
Andrew Geisslera2681d92020-10-16 10:17:07 -050082 DESTDIR='${WORKDIR}/minifi-install' cmake_runcmake_build --target ${OECMAKE_TARGET_INSTALL}
83 MINIFI_BIN=${bindir}
84 MINIFI_HOME=${sysconfdir}/minifi
85 MINIFI_RUN=${localstatedir}/lib/minifi
86 MINIFI_LOG=${localstatedir}/log/minifi
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050087
88 install -d ${D}${MINIFI_BIN}
89 install -d ${D}${MINIFI_HOME}/conf
Andrew Geisslera2681d92020-10-16 10:17:07 -050090 install -m 755 -d ${D}${localstatedir}/lib/minifi
91 cp -a ${WORKDIR}/minifi-install/usr/bin/* ${D}${MINIFI_BIN}/
92 cp -a ${WORKDIR}/minifi-install/usr/conf/* ${D}${MINIFI_HOME}/conf/
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050093
94 sed -i 's|#appender.rolling.directory=.*|appender.rolling.directory='${MINIFI_LOG}'|g' \
95 ${D}${MINIFI_HOME}/conf/minifi-log.properties
96 sed -i 's|nifi.provenance.repository.directory.default=.*|nifi.provenance.repository.directory.default='${MINIFI_RUN}'/provenance_repository|g' \
97 ${D}${MINIFI_HOME}/conf/minifi.properties
98 sed -i 's|nifi.flowfile.repository.directory.default=.*|nifi.flowfile.repository.directory.default='${MINIFI_RUN}'/flowfile_repository|g' \
99 ${D}${MINIFI_HOME}/conf/minifi.properties
100 sed -i 's|nifi.database.content.repository.directory.default=.*|nifi.database.content.repository.directory.default='${MINIFI_RUN}'/content_repository|g' \
101 ${D}${MINIFI_HOME}/conf/minifi.properties
102 sed -i 's|nifi.flow.configuration.file=.*|nifi.flow.configuration.file='${MINIFI_HOME}'/conf/config.yml|g' \
103 ${D}${MINIFI_HOME}/conf/minifi.properties
104
105 sed -i 's|export MINIFI_HOME=.*|export MINIFI_HOME='${MINIFI_HOME}'|g' ${D}${MINIFI_BIN}/minifi.sh
106 sed -i 's|bin_dir=${MINIFI_HOME}/bin|bin_dir='${MINIFI_BIN}'|g' ${D}${MINIFI_BIN}/minifi.sh
Andrew Geisslera2681d92020-10-16 10:17:07 -0500107 sed -i 's|pid_file=${bin_dir}/.|pid_file='${localstatedir}/run/'|g' ${D}${MINIFI_BIN}/minifi.sh
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -0500108
109 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
110 install -d ${D}${sysconfdir}/tmpfiles.d/
Andrew Geisslera2681d92020-10-16 10:17:07 -0500111 install -m 0644 ${WORKDIR}/systemd-volatile.conf ${D}${sysconfdir}/tmpfiles.d/minifi.conf
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -0500112 install -m 0755 -d ${D}${systemd_unitdir}/system
113 install -m 0644 ${WORKDIR}/minifi.service ${D}${systemd_unitdir}/system/
114
115 sed -i 's|@LOCALSTATEDIR@|${localstatedir}|g' ${D}${systemd_unitdir}/system/minifi.service
116 sed -i 's|@SYSCONFDIR@|${sysconfdir}|g' ${D}${systemd_unitdir}/system/minifi.service
117 sed -i 's|@BINDIR@|${bindir}|g' ${D}${systemd_unitdir}/system/minifi.service
118
Andrew Geisslera2681d92020-10-16 10:17:07 -0500119 sed -i 's|@MINIFI_LOG@|'${MINIFI_LOG}'|g' ${D}${sysconfdir}/tmpfiles.d/minifi.conf
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -0500120
121 elif ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
122 install -d ${D}${sysconfdir}/default/volatiles
123 install -m 0644 ${WORKDIR}/sysvinit-volatile.conf ${D}${sysconfdir}/default/volatiles/99_minifi
124
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -0500125 sed -i 's|@MINIFI_LOG@|'${MINIFI_LOG}'|g' ${D}${sysconfdir}/default/volatiles/99_minifi
126 fi
127}
128
129pkg_postinst_${PN}() {
130 if [ -z "$D" ]; then
131 if type systemd-tmpfiles >/dev/null; then
132 systemd-tmpfiles --create
133 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
134 ${sysconfdir}/init.d/populate-volatile.sh update
135 fi
136 fi
137}