blob: 03ae4c9db407496ae8562932a428dd9a36faaad8 [file] [log] [blame]
Andrew Geisslerd221e032020-07-10 16:13:21 -05001SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python."
Brad Bishop19323692019-04-05 15:28:33 -04002HOMEPAGE = "https://www.h5py.org/"
3SECTION = "devel/python"
Brad Bishop2d39a062019-10-28 08:33:36 -04004LICENSE = "BSD-3-Clause"
Andrew Geisslerd221e032020-07-10 16:13:21 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"
Brad Bishop19323692019-04-05 15:28:33 -04006
Andrew Geissler97771a32021-03-05 15:23:11 -06007SRC_URI[sha256sum] = "1e2516f190652beedcb8c7acfa1c6fa92d99b42331cbef5e5c7ec2d65b0fc3c2"
Andrew Geisslerd221e032020-07-10 16:13:21 -05008
9SRC_URI_append = " \
Andrew Geisslerac970dd2021-02-12 15:32:45 -060010 file://0001-setup_build.py-avoid-absolute-path.patch \
Andrew Geissler97771a32021-03-05 15:23:11 -060011 file://0001-setup.py-Fix-numpy-version.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012 "
Brad Bishop19323692019-04-05 15:28:33 -040013
Andrew Geisslerd221e032020-07-10 16:13:21 -050014inherit pypi setuptools3
Brad Bishop19323692019-04-05 15:28:33 -040015
16BBCLASSEXTEND = "native"
17
18DEPENDS = "python3-pkgconfig-native \
19 python3-cython-native \
20 python3-numpy-native \
21 python3-six-native \
22 python3 \
23 hdf5 \
24 "
25
26RDEPENDS_${PN} = "python3-numpy \
27 python3-six \
28 "
29
Andrew Geisslerd221e032020-07-10 16:13:21 -050030export HDF5_VERSION="1.8.21"