blob: 640adf83b7f903a228368e5ac1332b7a80f62f33 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Run-time type checker for Python"
2HOMEPAGE = "https://pypi.org/project/typeguard/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
5
Andrew Geissler97771a32021-03-05 15:23:11 -06006SRC_URI[sha256sum] = "33243c1cbfcb9736a06c6db22dd08876b5f297e6344aa272a2862c0f8e669f64"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
Andrew Geissler748a4832020-07-24 16:24:21 -05008inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS_${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \
16 ${PYTHON_PN}-typing-extensions \
17 ${PYTHON_PN}-unixadmin \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25DEPENDS += "\
26 python3-distutils-extra-native \
27 python3-setuptools-scm-native \
28"
29
Andrew Geissler82c905d2020-04-13 13:39:40 -050030BBCLASSEXTEND = "native nativesdk"