blob: 3f3c0e9028a29d8ab8d5bc04bf50918aeae28534 [file] [log] [blame]
Brad Bishop08902b02019-08-20 09:16:51 -04001SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
4 file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
5
6SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz"
Andrew Geissler4ed12e12020-06-05 18:00:41 -05007SRC_URI[md5sum] = "c91529e579483f44fb330052872b9c73"
8SRC_URI[sha256sum] = "31565649ff0e2d8dff1b8f7f2264ab7a78452063c7e04adfc4ce03e64b655080"
Brad Bishop08902b02019-08-20 09:16:51 -04009
10UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html"
11
Brad Bishop6dbb3162019-11-25 09:41:34 -050012inherit meson features_check lib_package bash-completion
Brad Bishop08902b02019-08-20 09:16:51 -040013
Andrew Geissler82c905d2020-04-13 13:39:40 -050014DEPENDS_append = " python3"
15
Brad Bishop08902b02019-08-20 09:16:51 -040016# This should be overridden per-machine to reflect the capabilities of the GL
17# stack.
18PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11-egl', '', d)} \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
20 surfaceless-egl gbm"
21
22# virtual/libgl requires opengl in DISTRO_FEATURES.
23REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('DEPENDS', 'virtual/${MLPREFIX}libgl', 'opengl', '', d)}"
24
25# I say virtual/libgl, actually wants gl.pc
26PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/${MLPREFIX}libgl libx11"
27
28# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
29# DISTRO_FEATURE.
30PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,virtual/${MLPREFIX}libgl wayland"
31
32# I say virtual/libgl, actually wants gbm.pc egl.pc
33PACKAGECONFIG[gbm] = "-Dgbm=enabled,-Dgbm=disabled,virtual/${MLPREFIX}libgl udev"
34
35# I say virtual/libgl, actually wants egl.pc
36PACKAGECONFIG[x11-egl] = "-Dx11_egl=enabled,-Dx11_egl=disabled,virtual/${MLPREFIX}libgl libxcb"
37PACKAGECONFIG[surfaceless-egl] = "-Dsurfaceless_egl=enabled,-Dsurfaceless_egl=disabled,virtual/${MLPREFIX}libgl"
38
39# TODO: optionally build manpages and examples