blob: d0bc0196163081b8880bd1b68ba636fe88360922 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "An HTTP library implementation in C"
2HOMEPAGE = "https://wiki.gnome.org/Projects/libsoup"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4SECTION = "x11/gnome/libs"
5LICENSE = "LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8DEPENDS = "glib-2.0 glib-2.0-native libxml2 sqlite3 intltool-native libpsl"
9
10SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/libsoup/${SHRT_VER}/libsoup-${PV}.tar.xz"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060013SRC_URI[sha256sum] = "170c3f8446b0f65f8e4b93603349172b1085fb8917c181d10962f02bb85f5387"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15CVE_PRODUCT = "libsoup"
16
17S = "${WORKDIR}/libsoup-${PV}"
18
19inherit meson gettext pkgconfig upstream-version-is-even gobject-introspection gtk-doc
20
21GIR_MESON_ENABLE_FLAG = 'enabled'
22GIR_MESON_DISABLE_FLAG = 'disabled'
23
24# libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards. Disable by default.
25PACKAGECONFIG ??= ""
26PACKAGECONFIG[gnome] = "-Dgnome=true,-Dgnome=false"
27PACKAGECONFIG[gssapi] = "-Dgssapi=enabled,-Dgssapi=disabled,krb5"
28
29EXTRA_OEMESON_append = " -Dvapi=disabled -Dtls_check=false"
30
31GTKDOC_MESON_OPTION = "gtk_doc"
32
33# When built without gnome support, libsoup-2.4 will contain only one shared lib
34# and will therefore become subject to renaming by debian.bbclass. Prevent
35# renaming in order to keep the package name consistent regardless of whether
36# gnome support is enabled or disabled.
37DEBIAN_NOAUTONAME_${PN} = "1"
38
39# glib-networking is needed for SSL, proxies, etc.
40RRECOMMENDS_${PN} = "glib-networking"
41
Andrew Geissler5a43b432020-06-13 10:46:56 -050042BBCLASSEXTEND = "native nativesdk"