Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "A toolkit to write, run and analyze benchmarks" |
| 2 | DESCRIPTION = " \ |
| 3 | The Python pyperf module is a toolkit to write, run and analyze benchmarks. \ |
| 4 | Features: \ |
| 5 | * Simple API to run reliable benchmarks \ |
| 6 | * Automatically calibrate a benchmark for a time budget. \ |
| 7 | * Spawn multiple worker processes. \ |
| 8 | * Compute the mean and standard deviation. \ |
| 9 | * Detect if a benchmark result seems unstable. \ |
| 10 | * JSON format to store benchmark results. \ |
| 11 | * Support multiple units: seconds, bytes and integer. \ |
| 12 | " |
| 13 | LICENSE = "MIT" |
| 14 | LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8" |
| 15 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "498bb4d1fe21350c2b7c1aa8bb3eae9c9979358d0b66327954bc66839fcba8b6" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS += "${PYTHON_PN}-six-native" |
| 19 | |
| 20 | PYPI_PACKAGE = "pyperf" |
| 21 | inherit pypi setuptools3 |
| 22 | |
| 23 | RDEPENDS_${PN} += "${PYTHON_PN}-misc" |