blob: c3789b0c1a35202e20c0d638fb014dc3cf8b15c6 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "GNOME disk utility"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SECTION = "x11/gnome"
6
7DEPENDS = " \
8 gtk+3 \
9 libdvdread \
Andrew Geissler9aee5002022-03-30 16:27:02 +000010 libnotify \
11 libsecret \
12 libpwquality \
13 udisks2 \
14 libhandy \
15"
16
17GNOMEBASEBUILDCLASS = "meson"
18
19inherit gnomebase gsettings gtk-icon-cache gettext features_check mime-xdg
20
Andrew Geissler78b72792022-06-14 06:47:25 -050021ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
22REQUIRED_DISTRO_FEATURES = "polkit"
Andrew Geissler9aee5002022-03-30 16:27:02 +000023
Andrew Geissler78b72792022-06-14 06:47:25 -050024PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd x11', d)}"
Andrew Geissler9aee5002022-03-30 16:27:02 +000025
26# As soon as elogind is of interest this needs rework: meson option is combo
27PACKAGECONFIG[systemd] = "-Dlogind=libsystemd,-Dlogind=none,systemd"
Andrew Geissler78b72792022-06-14 06:47:25 -050028PACKAGECONFIG[x11] = ",,libcanberra"
Andrew Geissler9aee5002022-03-30 16:27:02 +000029
Andrew Geissler78b72792022-06-14 06:47:25 -050030SRC_URI:append = " ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'file://0001-gnome-disk-utility-remove-libcanberra-dependency.patch', '', d)}"
Andrew Geissler9aee5002022-03-30 16:27:02 +000031SRC_URI[archive.sha256sum] = "1b6564454d67426322cb3bfc5a5558653bfc7dfeea2ae0825b1d08629f01090b"
32
33EXTRA_OEMESON = "-Dman=false"
34
35FILES:${PN} += " \
36 ${datadir}/metainfo \
37 ${datadir}/dbus-1 \
38"